Subscribe

Using New-NcNetInterface against ONTAP 8.3.2 versus ONTAP 9.0

[ Edited ]

This started out as WFA inquiry but I can reproduce the problem with just PowerShell. I am attempting to create a new LIF after creating a new SVM. The issue seems to have to do with Routing-Groups which were depricated in ONTAP 8.3 and even more so in ONTAP 9.0. The New-NcNetInterface cmdlet has a -RoutingGroup parameter which I'm leaving off. ONTAP 9.0 seems to want or need it but I have no idea what to give it since there are no routing-groups in ONTAP 9.0. ONTAP 8.3.2 seems to still support the concept (i.e.; Get-NcNetInterface will return the routing-group attribute of a LIF with a name like the old d192.168.0.0/24) but ONTAP 9.0 returns nothing ... hence I do not have anything to feed the -RoutingGroup parameter. Here is my testing. Am I missing something?

 


PS C:> $psversiontable.PSVersion

Major Minor Build Revision
----- ----- ----- --------
5 1 14393 693


PS C:> Get-NaToolkitVersion

Major Minor Build Revision
----- ----- ----- --------
4 1 0 0

 

PS C:>
PS C:> # First Against a 9.0 cluster (NOTE: the vserver is pre-existing at this point)
PS C:>
PS C:> Connect-NcController lt-stor.tnt.com -cred $cred

Name Address Vserver Version
---- ------- ------- -------
lt-stor.tnt.com 192.168.0.200 NetApp Release 9.0: Fri Aug 19 06:39:33 UTC 2016


PS C:> New-NcNetInterface -Name lt-dscdrtest004 -Vserver lt-dscdrtest004 -role data -node lt-stor-01 -Port e0d -Address 192.168.0.214 -Netmask 255.255.255.0 -DataProtocols @('cifs','nfs')
New-NcNetInterface : Internal error. Routing group not found. Contact technical support for assistance.
At line:1 char:1
+ New-NcNetInterface -Name lt-dscdrtest004 -Vserver lt-dscdrtest004 -ro ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (lt-stor.tnt.com:NcController) [New-NcNetInterface], EAPIERROR
+ FullyQualifiedErrorId : ApiException,DataONTAP.C.PowerShell.SDK.Cmdlets.Net.NewNcNetInterface

PS C:>
PS C:>
PS C:> # Now Against an 8.3.2 cluster (NOTE: the vserver is pre-existing at this point)
PS C:>
PS C:> Connect-NcController hq-stor.tnt.com -cred $cred

Name Address Vserver Version
---- ------- ------- -------
hq-stor.tnt.com 192.168.0.120 NetApp Release 8.3.2: Tue Feb 23 23:35:06 UTC 2016


PS C:> New-NcNetInterface -Name hq-dscdrtest001-02 -Vserver hq-dscdrtest001 -role data -node hq-stor-01 -Port e0d -Address 192.168.0.134 -Netmask 255.255.255.0 -DataProtocols @('cifs','nfs')

InterfaceName OpStatus DataProtocols FirewallPolicy Vserver Address
------------- -------- ------------- -------------- ------- -------
hq-dscdrtest001-02 up {nfs, cifs} data hq-dscdrtest001 192.168.0.134

 

PS C:>

 

 

Re: Using New-NcNetInterface against ONTAP 8.3.2 versus ONTAP 9.0

Hi @dkorns,

 

Does a route/gateway for that subnet exist on the SVM?

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Using New-NcNetInterface against ONTAP 8.3.2 versus ONTAP 9.0

Thanks Andrew,

 

Good question, and no, there is no route (yet). I was thinking that would be done after creating the LIF since that is what some code Im looking at does (from a WFA command). But I re-tested creating a route before creating the LIF ... but it still complains about wanting a Routing-Group (or -RoutingGroup param). Maybe 

 

PS C:> Connect-NcController lt-stor.tnt.com -cred $cred

Name Address Vserver Version
---- ------- ------- -------
lt-stor.tnt.com 192.168.0.200 NetApp Release 9.0: Fri Aug 19 06:39:33 UTC 2016


PS C:> New-NcNetInterface -Name lt-dscdrtest004 -Vserver lt-dscdrtest004 -role data -node lt-stor-01 -Port e0d -Address 192.168.0.214 -Netmask 255.255.255.0 -DataProtocols @('cifs','nfs')
New-NcNetInterface : Internal error. Routing group not found. Contact technical support for assistance.
At line:1 char:1
+ New-NcNetInterface -Name lt-dscdrtest004 -Vserver lt-dscdrtest004 -ro ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (lt-stor.tnt.com:NcController) [New-NcNetInterface], EAPIERROR
+ FullyQualifiedErrorId : ApiException,DataONTAP.C.PowerShell.SDK.Cmdlets.Net.NewNcNetInterface

PS C:\Users\davekorns> New-NcNetRoute -Destination 0.0.0.0/0 -Gateway 192.168.0.1 -Metric 20 -VserverContext lt-dscdrtest004

Destination Gateway Metric Vserver
----------- ------- ------ -------
0.0.0.0/0 192.168.0.1 20 lt-dscdrtest004


PS C:> New-NcNetInterface -Name lt-dscdrtest004 -Vserver lt-dscdrtest004 -role data -node lt-stor-01 -Port e0d -Address 192.168.0.214 -Netmask 255.255.255.0 -DataProtocols @('cifs','nfs')
New-NcNetInterface : Internal error. Routing group not found. Contact technical support for assistance.
At line:1 char:1
+ New-NcNetInterface -Name lt-dscdrtest004 -Vserver lt-dscdrtest004 -ro ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (lt-stor.tnt.com:NcController) [New-NcNetInterface], EAPIERROR
+ FullyQualifiedErrorId : ApiException,DataONTAP.C.PowerShell.SDK.Cmdlets.Net.NewNcNetInterface

PS C:> Get-NcNetInterface | select InterfaceName,routingGroupName

InterfaceName RoutingGroupName
------------- ----------------
cluster_mgmt
lt-stor-01_mgmt1
lt-stor-01_repl1
lt-vs0_cifs_nfs_lif1

 

 

Notice in the last command returning blank for RoutingGroupName ... which I think is ONTAP standard behaviour but can't udnerstand why New-NcNetInterface seems to require it. I'm probaly confused.

 

Re: Using New-NcNetInterface against ONTAP 8.3.2 versus ONTAP 9.0

I tested your code with my ONTAP 9.0P1 system using ONTAP modules 4.1 and didn't encounter the error...

 

PS C:\Users\asull> New-NcNetInterface -Name ndc_test -Vserver NDC -Role data -node VICE-07 -port a0a-10 -Address 172.16.13.110 -NetmaskLength 24 -DataProtocols cifs,nfs

InterfaceName        OpStatus DataProtocols        FirewallPolicy Vserver              Address                                                                        
-------------        -------- -------------        -------------- -------              -------                                                                        
ndc_test                up    {nfs, cifs}               data      NDC                  172.16.13.110                                                                  



PS C:\Users\asull> Get-NcNetInterface -Vserver NDC

InterfaceName        OpStatus DataProtocols        FirewallPolicy Vserver              Address                                                                        
-------------        -------- -------------        -------------- -------              -------                                                                        
NDC_nfs_lif1            up    {nfs, cifs}               mgmt      NDC                  172.16.10.10                                                                   
ndc_test                up    {nfs, cifs}               data      NDC                  172.16.13.110                                                                  

Maybe something else in the network configuration is missing?

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Using New-NcNetInterface against ONTAP 8.3.2 versus ONTAP 9.0

Thanks Andrew ... could you do me a Get-NcNetRoute on that same system for comparison w/mine. I'm beginning to believe it could be a config issue. I had all this working w/8.3.2 and since I've introduced 9.0 in the mix I'm hitting this. 

 

Also, on -NetMask versus -NetMaskLength ... I thought (possibly mistaken) -NetMaskLength was only for IPv6, so I set -NetMask (255.255.255.0) and either leave -NetMaskLength blank or pass 0 sometiems. I notice you just use -NetMaskLength 24 by itself ... in the IPv4 case does that get treated as 255.255.255.0?

 

Re: Using New-NcNetInterface against ONTAP 8.3.2 versus ONTAP 9.0

Here is the Get-NcNetRoute output.  Note that I created a dummy LIF using a subnet that previously did not exist on a port which did exist (so, I overloaded the port with more than one subnet).

 

PS C:\Users\asull> Get-NcNetRoute -Vserver NDC

Destination          Gateway              Metric Vserver                                                                                                              
-----------          -------              ------ -------                                                                                                              
0.0.0.0/0            172.16.10.1            20   NDC                 

Regarding "Netmask" vs "NetmaskLength", I have always used them interchangably with the difference being one is in IP notation, the other is an integer.

 

NetmaskLengh 24 == Netmask 255.255.255.0

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Using New-NcNetInterface against ONTAP 8.3.2 versus ONTAP 9.0

Hi,

 

I'm new to this community.

 

I have the same problem in da script for creating a DR SVM.

As i analysed the difference between 8.3.2 and 9.0 is, that you don't need / can't use RoutingGroupName anymore.

 

so your script has to be aware witch ONTAP Version the controller runs.

 

R
Michael