Subscribe
Accepted Solution

e0i not configured after a reboot when using Set-NaNetInterface in advance

After using Set-NaNetinterface regardless of which changes have been applied the rc file looks like this. After a takeover/giveback the e0i Ports or e0a on older systems doesn't come up because it is not configured. It seems that the mediatype parameter prevents that. When I delete the mediatype parameter from the ifconfig e0i* line and issue the command again the port gets configured. Any time you use Set-NaNetInterface the mediatype parameter is added to the ifconfig line again. That's very inconvenient as I use the cmdlet to have the rc file updated automatically.

This seems to happen on systems > Ontap 8.2.3. Is it a new bug with net-config-set-persistent ZAPI like 710228?

 

#Auto-generated by zapi_net_config Wed Sep 30 08:22:38 CEST 2015
hostname D100BPMC040
ifgrp create lacp vif14 -b ip e0a e0c
vlan create  vif14 3100
vlan add vif14 3103
vlan add vif14 3108
vlan add vif14 3109
ifconfig e0a mediatype auto-10g_sr-fd-up mtusize 9000 up
ifconfig e0b mediatype auto-unknown-down up
ifconfig e0c mediatype auto-10g_sr-fd-up mtusize 9000 up
ifconfig e0d mediatype auto-unknown-down up
ifconfig e0i `hostname`-e0i netmask 255.255.255.0 broadcast 4.249.24.255 mediatype auto-1000t-fd-up partner e0i up
ifconfig e0j mediatype auto-unknown-down up
ifconfig e0k mediatype auto-unknown-down up
ifconfig e0l mediatype auto-unknown-down up
ifconfig e0M mediatype auto-1000t-fd-up up
ifconfig e0P down
ifconfig vif14 mtusize 9000 up
ifconfig vif14-3100 `hostname`-vif14-3100 netmask 255.255.255.0 broadcast 10.4.224.255 partner vif14-3100 up
ifconfig vif14-3108 `hostname`-vif14-3108 netmask 255.255.255.0 broadcast 10.4.232.255 partner vif14-3108 mtusize 9000 up
ifconfig vif14-3108 alias 10.4.232.252 netmask 255.255.255.0 broadcast 10.4.232.255 up
ifconfig vif14-3109 `hostname`-vif14-3109 netmask 255.255.255.0 broadcast 10.4.233.255 partner vif14-3109 mtusize 9000 up
ifconfig vif14-3109 alias 10.4.233.252 netmask 255.255.255.0 broadcast 10.4.233.255 up
ifconfig vif14-3103 partner vif14-3103 mtusize 9000 up
route add net default 4.249.24.1 1
routed on
options dns.domainname d100.intern
options dns.enable on
options nis.enable off
savecore

 

Re: e0i not configured after a reboot when using Set-NaNetInterface in advance

I think you might be seeing an undesired result of this fix:  

 

http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=820862

 

It looks like why that command fails can be found in the MAN page for IFCONFIG:  

 

https://library.netapp.com/ecmdocs/ECMP1511537/html/man1/na_ifconfig.1.html

 

Refer to the statement: "All 1000Base-T devices support autonegotiation and the speed cannot be explicitly set to 1000 Mbps."

 

I have updated our internal team who worked on resolving the issue in the bug report at the top of this issue you are seeing.

Re: e0i not configured after a reboot when using Set-NaNetInterface in advance

Great,

that's it. Thanks. I wrote a powershell script that changes the rc-file afterwards. Maybe of interest for others

 

read-nafile /vol/$((get-navolroot).name)/etc/rc | out-file $input_file
get-content $input_file | foreach {
    if ($_ -match "^ifconfig") {
        $out = $_ -replace "(mediatype auto[-_A-Za-z0-9]+\s)",''
        Add-Content -Path $output_file -Value $out
    }
    else {
        Add-Content -Path $output_file -Value $_
    }
}
get-content $output_file

 

 

Re: e0i not configured after a reboot when using Set-NaNetInterface in advance

Hi, skellner-san,

 

Our customer faces the same problem now.

Your report is very useful for us, thank you.

 

I want to confirm 2 things:

1. Does this bug(?) not fixed yet on 8.2.3?

mcgue-san commented above:

"I have updated our internal team who worked on resolving the issue in the bug report at the top of this issue you are seeing."

 

Did you get any update of it?

 

2. The problem was fixed by applying your script?

I'll try to apply it, but I want to confirm that it works right?

 

Thanks and Regards,

Masaki

Re: e0i not configured after a reboot when using Set-NaNetInterface in advance

[ Edited ]

Hi Masaki

 

The issue sounds like BURT 746803. I posted a workaround solution to this here:

 

http://community.netapp.com/t5/OnCommand-Storage-Management-Software-Discussions/Powershell-Add-NaNetRoute-messing-with-etc-rc-file/m-p/112465#M19906

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: e0i not configured after a reboot when using Set-NaNetInterface in advance

Thank you Matt-san,

 

I'll check your workaround solution.

 

Thanks and Regards,

Masaki