Subscribe
Accepted Solution

new-ncvol fails when directly connected to vServer as vsadmin

When trying to create a volume when directly connected to a vserver as vsadmin the volume create fails indicating the aggr does not exist (see error below).  Tested on additional vservers with different aggregates, same error.  Is New-NcVol not supported as 'vsadmin'?

PS C:\Users\v-jerryb> Connect-NcController 10.58.33.XXX -cred vsadmin

Name                 Address           Vserver              Version

----                 -------           -------              -------

10.58.33.126         10.58.33.126      vs1_HPV_FC           NetApp Release 8.2P4 Cluster-Mode: Tue Oct 01 15:03:27 P

PS C:\Users\v-jerryb> new-ncvol vol_test2 aggr1_node4_300GB15K_data 10g -JunctionPath /vol_test2

new-ncvol : Aggregate aggr1_node4_300GB15K_data does not exist

At line:1 char:1

+ new-ncvol vol_test2 aggr1_node4_300GB15K_data 10g -JunctionPath /vol_test2

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : InvalidOperation: (10.58.33.126:NcController) [New-NcVol], EAGGRDOESNOTEXIST

    + FullyQualifiedErrorId : ApiException,DataONTAP.C.PowerShell.SDK.Cmdlets.Volume.NewNcVol

Validate aggregates exist:

PS C:\Users\v-jerryb> Connect-NcController 10.58.33.44 -cred root

Name                 Address           Vserver              Version

----                 -------           -------              -------

10.58.33.xx          10.58.33.xx                            NetApp Release 8.2P4 Cluster-Mode: Tue Oct 01

PS C:\Users\v-jerryb> get-ncaggr

Name                      State       TotalSize  Used  Available Disks RaidType        RaidSize  Volumes

----                      -----       ---------  ----  --------- ----- --------        --------  -------

aggr0_node1_root          online       239.0 GB   95%    11.1 GB   3   raid_dp, normal    16           1

aggr0_node2_root          online       239.0 GB   95%    11.1 GB   3   raid_dp, normal    16           1

aggr0_node3_root          online       227.1 GB   95%    10.4 GB   3   raid_dp, normal    16           1

aggr0_node4_root          online       227.1 GB   95%    10.4 GB   3   raid_dp, normal    16           1

aggr1_node1_300GB15K_data online         1.4 TB    7%     1.3 TB   8   raid_dp, normal    16           5

aggr1_node2_300GB15K_data online         1.4 TB    0%     1.4 TB   8   raid_dp, normal    16           1

aggr1_node3_300GB15K_data online         1.9 TB    0%     1.9 TB  10   raid_dp, normal    16           2

aggr1_node4_300GB15K_data online         1.9 TB    0%     1.9 TB  10   raid_dp, normal    16           2

Re: new-ncvol fails when directly connected to vServer as vsadmin

Hi Jerry,

Is the target aggregate part of the Vserver's aggregate list?

PS C:\> Get-NcVserver beam01 | select Vserver, VserverAggrInfoList

Vserver                                                     VserverAggrInfoList

-------                                                     -------------------

beam01                                                      {aggr1}

You can modify the aggregate list using Set-NcVserver:

PS C:\> help Set-NcVserver -Parameter Aggregates

-Aggregates <String[]>

    The list of aggregates assigned for volume operations.  These aggregates could be shared for use with other

    vservers.

    Required?                    false

    Position?                    named

    Default value

    Accept pipeline input?       false

    Accept wildcard characters?  false

-Steven

Re: new-ncvol fails when directly connected to vServer as vsadmin

Thanks - so simple.  Overlooked the aggregates were not delegated for volume creation.

Thanks,

Jerry