Subscribe

Can't access cifs hidden homedirs

Hi

We're migrating from windows FS to cifs. I've robocopied all our user folders across to the filer, and set the homedirs as hidden. All our users have a folder named the same as their domain logon. We can't seem to map drives to the user homedirs.....

If the user tries to connect by doing \\filer\cifs.homedir, everything works, but if they try to connect by doing \\filer\jouser$ it fails.

Any ideas why and what I can do to resolve it?

Thanks

Chris

Re: Can't access cifs hidden homedirs

\\filer\jouser$ would suggest that you've created a separate (hidden) share for every user, which is probably not the case right? You probably created a single hidden share for user's homedirs - and moved their folders there. If that's the case, try \\filer\sharename$\user.

Re: Can't access cifs hidden homedirs

Hi Chris,

We have just run through exactly the same setup you have tried and managed to get it working.

Are you planning to setup the homedirs directly from the filer or are you using a vfiler for the home directory share?.

One option worth checking would be if you map a network drive to filer\ETC$ then open the cifs_homedir.cfg

You should then see something similar to the info below;

#
# This file contains the path(s) used by the filer to determine if a
# CIFS user has a home directory. See the System Administrator's Guide
# for a full description of this file and a full description of the
# CIFS homedir feature.
#
# There is a limit to the number of paths that may be specified.
# Currently that limit is 1000.
# Paths must be entered one per line.
#
# After editing this file, use the console command "cifs homedir load"
# to make the filer process the entries in this file.
#
# Note that the "#" character is valid in a CIFS directory name.
# Therefore the "#" character is only treated as a comment in this
# file if it is in the first column.
#
# Two example path entries are given below.
# /vol/vol0/users1
# /vol/vol1/users2
#
/vol/ukbr01a_agg1_vfiler1/home/
(This will need to match the volume name and share you have created)

For example in our environment I then created a folder with my username in the home directory. Then i could map directly to %filername%\mgreav2$

Another option also to try help with troubleshooting would be from the CLI run the following command cifs homedir showuser (username)

This should then give you an output similar to the screenshot attached.

Let me know how you get on.

Thanks

Mat

Re: Can't access cifs hidden homedirs

It sounds like options cifs.home_dir_namestyle hidden ... several options and hidden seems the one you are looking for for username$ to work ... other options are ntname, domain, mapped