Subscribe

Change in CIFS functionality since upgrade to ONTAP 9.1

We upgraded our 2 Clusters from ONTAP 8.3.2 to 9.1

 

Since upgrading we have noticed a change when trying to access a CIFS share when the user connecting is logged onto a different AD domain to the SVM.

 

The end user no longer get challenged for a user ID and password. Instead because the user ID is the same it tries to use the users credentials including password to connect and after a while the end user gets the following errors

 

System error 64 has occurred.

 

The specified network name is no longer available.

 

If the end user keeps trying to access it, their account on the AD domain that the SVM is on will become locked.

 

However if they specify their credentials including password from the command line, i.e. net use \\CIFS_SVM\share_name /user:{user_id} {password}

then it works and they can then access the share. They can also do this from the GUI and it also works.

 

so we have a workaround, but just wondered why the difference between 8.3.2 and 9.1 is it a bug or intentional? 

Re: Change in CIFS functionality since upgrade to ONTAP 9.1

Hi,

 

Refer KB https://kb.netapp.com/support/s/article/ka11A0000000s6A/clients-cannot-access-the-filer-anymore-after-migrating-from-one-trusted-domain-to-another-err...

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Change in CIFS functionality since upgrade to ONTAP 9.1

Hi Sahana,

 

Even though I have licensed support with Netapp I don't seem to have access to that article.

Re: Change in CIFS functionality since upgrade to ONTAP 9.1

Hi,

 

You need a customer login account to access it. If you do not have one, you can register and create an account.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Change in CIFS functionality since upgrade to ONTAP 9.1

I do have an account but it tells me I don't have access to the knowledgebase.

Re: Change in CIFS functionality since upgrade to ONTAP 9.1

I'm not sure if this is the same issue, we have not migrated to another Domain, there is no trust between the domain the end users are on and the domain the SVM is on