Subscribe

Cifs login issue

Hello,

I am facing some issues when trying to access my volumes or qtrees from my windows host.

So I created a qtree and exported it.


/vol/vol1/datatree1     -sec=sys,rw
ironman2-vm0>

I can access my filer by typing in \\IP Address

I see the qtree there

When I try to access it. I am prompted for login creds. I use the root credentials and it does not accept it.

U:root

P:1234

I created another user account as an administrator and the same thing happens

U:test

P:1234

When I tried using a user located in the guest group

I actually get a window saying I may not have permissions to view this share.

any ideas what the issue is?

Re: Cifs login issue

One thing I have noticed is that the local name I created to test with is not stored in the /etc/passwd file.

According to my cifs sessions I am configured
Using Local Users authentication.

Could this be the issue? If so how can I manually add someone's credentials to the /etc.passwd file?

Thanks

Re: Cifs login issue

May I suggest the use of System Manager.  System Manager offers better interface than FilerView and using the command line, and it is all local.  To obtain the free system manager. Go to now.netapp.com and select download software and scroll down until you find it.  I have been through this many times, and yes you can add users to the /etc/passwd but that doesnt work 100% of the time.  The only time I have seen cifs setup work is when using Active Directory.  This will help and make management of your filer easier.

Using this tool you will be able to perform the task with no issue.  It just works, and I like that.

Re: Cifs login issue

You say you exported it and show an exportfs command...Have you run cifs shares -add datatree1 /vol/vol1/datatree1  ?  If you see the qtree via the UNC I would have to believe you have.  You can't access an exported qtree without a CIFS share to the same file system.

When connecting to CIFS shares you should use the administrator account, simply cleaner as you are using the account native to the file format.

As to your new user account not being in /etc/passwd, it won't be.  Unless you put them into the passwd and shadow file yourself, they are added to the registry.local file.