Subscribe
Accepted Solution

Configuring BranchCache on 7mode

Hi all.

 

My company has a FAS2240 in the main office that provides file server access to both the main and the remote offices. The remote office is experiencing latency problems and because of this access to the file server have become really slow.

 

So, I am trying to deploy a hosted BranchCache to the remote office, but it does not work. I have already enabled BC on the FAS and on the volume, as well as the secret:

 

cifs.smb2.enable on

cifs.smb2_1.branch_cache.enable on
cifs.smb2_1.branch_cache.hash_time_out 7200 (value might be overwritten in takeover)

 

NETAPP> cifs shares -change INSTALL$ -branchcache

1 share(s) have been successfully modified

 

Also I have already configured the Windows 2012 Cache Server (although I cannot find on Microsoft documentation where to indicate the "secret" or the remote file server) and the Windows 8 Enterprise client computer:

 

Server:

BranchCacheIsEnabled        : True

HostedCacheServerIsEnabled        : True

 

Client:

BranchCacheIsEnabled : True
BranchCacheServiceStatus : Running
CurrentClientMode : HostedCacheClient

HostedCacheServerList : {hosted_cache_server.domain.local}

But still I cannot get a hit on the filer:

 

NETAPP> cifs branchcache hash stat
Number of hashes flushed in duration of 600 seconds = 0
Number of hashes flushed in duration of 900 seconds = 0
Number of hashes flushed in duration of 1200 seconds = 0
Number of hashes flushed in duration of 1500 seconds = 0
Number of hashes flushed in duration of more than 1800 seconds = 0
Number of files (size <= 10KB) for which hashes were asked for = 0
Number of files (10KB < size <= 100KB) for which hashes were asked for = 0
Number of files (100KB < size <= 250k) for which hashes were asked for = 0
Number of files (250KB < size <= 1MB) for which hashes were asked for = 0
Number of files (1MB < size <= 10MB) for which hashes were asked for = 0
Number of files (10MB < size <= 100MB) for which hashes were asked for = 0
Number of files (size > 100MB) for which hashes were asked for = 0

 

Have anyone managed to get BranchCache working correctly?

 

Thanks in advance.

Re: Configuring BranchCache on 7mode

Please see if these links can be of any help.

 

Data ONTAP 8.2.3 File Access and Protocols Management Guide

https://library.netapp.com/ecm/ecm_download_file/ECMP1401220

 

How to control the SMB 2.1 feature in Data ONTAP 8.2.3 operating in 7-Mode

https://kb.netapp.com/support/index?page=content&id=1015064&locale=en_US

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: Configuring BranchCache on 7mode

Thanks for the reply, I managed to get it functioning correctly now.

Re: Configuring BranchCache on 7mode

Hi All,

 

we are facing the same issue. Please let us know how you fixed it.

 

All are configured from storage end perfectly

 

Thanks 

Mari