Subscribe

Data transfer from NETAPP storage to Mainframe Z/OS

Hello Guys,

Apology I am not from a NETAPP background but a mainframe guy.. I have challenging situation where we are not able to FETCH files from NETAPP storage to MAINFRAME Z/OS. From the Mainframe site, We are able to PING and TRACEROUTE the destination IP of NETAPP storage, but when we trying to Run FTP from mainframe to NETAPP we get the message as "Connection Refused). Here the Mainframe is acting as Client and NETAPP as Server. We tried discussing with our LOCAL netapp administrator about this and he claims that NETAPP storage never had FTP service enabled previously before migrating to a new storage and Mainframe users were able to download the File from NETAPP to Mainframe.

I am really curious if NETAPP does not have FTP service running then how does the Data transfer happens and which Port really helps this Transfer. Or there any Inbound Firewall rules within NETAPP which is refusing the connection made from mainframe ?

Could someone be kind enough to provide me some Hints or Pointers.

Jake

Re: Data transfer from NETAPP storage to Mainframe Z/OS

FTP server is enabled by setting options ftpd.enable on.  If your NetApp administrator refuses to turn it on, we can't really do anything about it.  Are you sure you were using FTP to do the data transfer to your mainframe previously?  User data transfer from NetApp storage to hosts are usually done via NFS exports or CIFS shares, or block access devices (LUNs).

Re: Data transfer from NETAPP storage to Mainframe Z/OS

The problem started when NETAPP storage was migrated to a new location. The data transfer is happening via CIFS shares and now when we try to download data form CIFS share we get a message as Connection refused.

Is there any enablement in CIFS share that can allow me to perform data transfer from NetApp to mainframe..

Re: Data transfer from NETAPP storage to Mainframe Z/OS

I couldn't reply to your private message because your email address is hidden.  Anyway...

you mentioned that this was working until the NetApp hardware was moved to a new location and the ip address was changed and CIFS no longer works.  There are so many things to check I don't even know where to begin.  Are the network settings on the NetApps all correctly set?  Assuming the system name(s) stayed the same, were the DNS entries changed to use the new IPs?  Are other CIFS shares (if any) on the NetApps accessible?  Is the storage able to join the domain (cifs sessions, cifs domaininfo)?  Try accessing the CIFS share in question from another client (like a Windows client instead of the mainframe and see if that works).