Subscribe
Accepted Solution

Facing problem in setting up Auto Home Shares

Hi All,

It seemed very simple at first but I seem to miss something. I am using FAS3210 and want to setup AuoHome Shares.

Previously on Win2008 R2, we use a share folder named "Users" which holds all user home directories, there we would set admins permissions to full rights. Then give all users read rights and stop this specific right propagation onto subfolders. In next step we would set Home Folder property in profile as \\servername\%username%

Below are steps which I performed on Filer,

Create a volume as users_vol (default ntfs)

Create a qtree  as users_qtree (ntfs)

Create a share as Users (\vol\users_vol\users_qtree)

As this share has Everyone "Full rights", I modified to only give read without further propagation

Now when I create a directory manually with ntname of user, I cant specify in Home Folder under profile Tab in AD "\\servername\%username%"

Also If I create login batch to connect it, it connects while user logs in but cant go in the drive

Also I want to ask, is it necessary to create a Main share like I have "Users" as there is nothing like it in autohome share documentation. But If I dont create it, how will I create a folder with user's ntname. Because using variable as \\servername\%username%   OR    \\servername\Users\%username%   both fail to create directory as it does in windows server environment.

Thanks and Regards,

Yasir Irfat

Re: Facing problem in setting up Auto Home Shares

Hey did you get this fixed? I am having the same issue as yours.

Thanks!

Gustavo del Pino

Re: Facing problem in setting up Auto Home Shares

No I did try several things but did not succeed, so i had to go routine way of creating a "Home" share and giving IT groups required accesses, and domain user list only rights (with limited to only current folder).

in user properties give path "\\filername\Home\%username%". all folders created this way get all rights setup properly.

Re: Facing problem in setting up Auto Home Shares

Not sure if this is going to be useful to you anymore since it sounds like you found your way around it, but after doing a bunch of research I found out that, for Ontap 6.4 and above, you can make user home directories visible to administratos by running:

filer> options cifs.home_dirs_public_for_admin on

And then when you go back to the Profile tab, you set the user's home folder to:

\\filer\~%username% (note the tilde in the name).

As soon as I added the tilde it worked. Amazing how a single character can make us spend hours of research.

Thanks for replying!

Gustavo del Pino

Re: Facing problem in setting up Auto Home Shares

Hi Gustavo,

Yes my steps were workaround or should i say, I absolutely did not use the feature and did it manually.

regarding home directly visibility to admins, i did set all parameters alongwith custom paths and selection of home directory naming convention, 

Well if that ~ sign was the cause, I must say I never found it in any documentation, either in book nor online manuals and they are all 7.2 and later documentations. Even I checked 8.0 without success.

Thanks a lot for this info, it will be very helpful and I will test it tomorrow and come back with results (hopefully positive).

Thanks and Regards,

Yasir Irfat

Re: Facing problem in setting up Auto Home Shares

Though one question I want to ask,

Are you creating a directory manually or setting the profile with variable in AD creates it automatically. And if we have to create it manually, can we create a directory without its parent (vol, qtree or folder) being shared. Is it possible to create a directory using a command through SSH connection by specifying path as /vol/home_vol/abc

Re: Facing problem in setting up Auto Home Shares

I already had a bunch of profile folders in another server, so right we are working on the migration and I moved all of them to my filer using Robocopy (to get the permissions across), so to answer your question yes, I create the directories manually. This is my structure:

\\filer\cifs\Users\home foldes...

only cifs is shared.

Hope that helps

Gustavo