Subscribe
Accepted Solution

Inodes Full 90%

I have a cifs volume which is using 90% 1.7 million out of 1.9 million of its volume. It is only 25GB in size. I thought increasing the volume size also increased the inode max count but increasing to 50GB vol size has not made any difference to the max 1.9m it has set. Have I missed a step? Do I need to run another command to expand the inodes?

any help much appreciated.

Re: Inodes Full 90%

Hi,

Have a look at 'maxfiles' command available on filer's CLI interface.

Cheers,

Vladimir

Re: Inodes Full 90%

You need to

type vol options /vol/VOLNAME

note value for maxdirsize

then type vol options /vol/VOLNAME maxdirsize=bigger number


Re: Inodes Full 90%

So If I use the following commands:

\\This shows the current and used maxfiles for the vol. It must be specified as just the name without /vol/ in front

> maxfiles <volname>

\\NetApp recommends adding 20% at a time as it can't be reduced. 20% would be good in my case and I have already expanded the volume by 50%

> maxfiles <volname> <max>

\\Checking inode usage on testvol

> maxfiles testvol

> Volume testvol: maximum number of files is currently 1899979 (1773835 used)

\\Increasing inode usage on testvol by 20%

> maxfiles testvol 2374973

I take it if the volume is deleted in the future the inodes would be freed up. I never like it when things cant be decreased. Makes you count those numbers very carefully.

Helpfull references

http://www.wafl.co.uk/maxfiles/

https://communities.netapp.com/docs/DOC-5027