Community

Subscribe
Highlighted

It is racked in and initial setup completed...now what?

Hello All

  Christmas came early in the form of a FAS2240-2, oh goddie new toys, now I have to make it work.  It is installed in the rack, cabled up, and powered up.  I consoled in and ran through the initial setup configuring e0M, e0a-d, and also ran the config checked which passes.  This being my first NetApp I figured that there has to be a doc map or something for me to follow and I found one in the doc library, so far so good.  Question though, am I cluster or 7-Mode?  I figured cluster, am I correct?

   I started going through docs and after reading through easily several hundred pages I realized that I was no farther ahead in the configuration than when I started.  I am a lot smarted on NetApp products than when I started, which is good, but as far as here are the basic steps you need to get the system up and running, nada.

  So question is, where does someone who has has other SAN vendor experience start?

TIA,

Jim

Re: It is racked in and initial setup completed...now what?

Hi Jim,

if you have access to the console, run the command "sysconfig". This will tell you what version of ONTAP you are running and the currently config of your interfaces.

You should get something back that looks like this. Most systems are still running ONTAP 7 Mode at the moment, unless you have specifically moved to Cluster Mode.

XXXXXXX> sysconfig

        NetApp Release 8.1.1RC1 7-Mode: Thu May 31 21:30:59 PDT 2012

        System ID: XXXXXXXXXX (XXXXXXXXXXXX); partner ID: XXXXXXXX (XXXXXXXXXXXX)

        System Serial Number: XXXXXXXXXXXX (XXXXXXXXXXXX)

check your disks and aggregate setup with the "aggr status" and check volumes and space currently used with "df -Ah".

you can then start setting up your volumes and other requirements through either NetApp OnCommand Systems Manager, or through Filerview (java Web based admin page, although this now no longer used/supported).

HTH

Re: It is racked in and initial setup completed...now what?

  Yep found it

fas2240-1> sysconfig

        NetApp Release 8.1.1 7-Mode: Mon Jul 30 12:49:46 PDT 2012

        System ID: XXXXXXXXXX (fas2240-1)

        System Serial Number: XXXXXXXXXXXXX (fas2240-1)

        System Rev: D0

        System Storage Configuration: Multi-Path

        System ACP Connectivity: Full Connectivity

        slot 0: System Board

                Processors:         4

                Processor type:     Intel(R) Xeon(R) CPU           C3528  @ 1.73GHz

                Memory Size:        6144 MB

                Memory Attributes:  Hoisting

                                    Normal ECC

                Controller:         A

        Service Processor           Status: Online

        slot 0: Internal 10/100 Ethernet Controller

                e0M MAC Address:    00:a0:98:31:c9:c9 (auto-100tx-fd-up)

                e0P MAC Address:    00:a0:98:31:c9:c8 (auto-100tx-fd-up)

        slot 0: Quad Gigabit Ethernet Controller 82580

                e0a MAC Address:    00:a0:98:31:c9:c4 (auto-1000t-fd-up)

                e0b MAC Address:    00:a0:98:31:c9:c5 (auto-unknown-down)

                e0c MAC Address:    00:a0:98:31:c9:c6 (auto-unknown-down)

                e0d MAC Address:    00:a0:98:31:c9:c7 (auto-unknown-down)

        slot 0: Interconnect HBA:   Mellanox IB MT25204

        slot 0: SAS Host Adapter 0a

                30 Disks:            10602.8GB

                1 shelf with IOM3, 1 shelf with IOM6E

        slot 0: SAS Host Adapter 0b

                30 Disks:            10602.8GB

                1 shelf with IOM3, 1 shelf with IOM6E

        slot 0: Intel ICH USB EHCI Adapter u0a (0xdf101000)

                boot0   Micron Technology Real SSD eUSB 2GB, class 0/0, rev 2.00/11.10, addr 2 1936MB 512B/sect (4BF0022700267746)

        slot 1: FC Host Adapter 1a

        slot 1: FC Host Adapter 1b

  So based on that we are in 7-Mode and not a cluster but we have two controllers so can we go cluster mode and if so how?  I know these are very basic questions, that is why I asked.  The goal is the have both VMware and CIFS Storage on the SAN.  Based on that how should we setup the networking?

  Configuration is different and I am trying to find my why just can't seem to find a good start point.

Jim

Re: It is racked in and initial setup completed...now what?

Hi Jim - in short no you cant go to cluster mode, as you would require another controller or two. You have a HA pair (2x controllers). You will be able to have CIFS and VMWare on your syste, but you will need to decide how you are going to connect VMWare and if you are going to use other protocols as you currently only have 4x NICs and ideally you need 2x per inteface group for resilience.

Are you using NFS & ISCSI as well? once you know this you could start creating your Interfaces, with VLANS if required and then testing the Filer setup, ie reboot, test Cluster failover etc.

Martin

Re: It is racked in and initial setup completed...now what?

martin,

  Thanks so much for the reply.  We will not have NFS or iSCSI on the system  The plan is to have one possibly two CIFSs shares and 1 VMware volume on the system, so I think we have enough NICs to support that.  VMware wil be conected using Fiber Channel and is alreay cabeled up.  I have configured the FC Fabric and can see the controllers.  I installed all the licenses and have reconfigured the system into HA mode which was very very easy.  My only remainig concern is how to utilize the Flash Pool.  I have not looked but am sure there is documentationon this somewhere onthe NetApp support site.

Jim