Subscribe
Accepted Solution

LUN is offline in Windows 2008 R2

Hi,

Greetings.

I have created a LUN and exported to a Windows 2008 R2 server where LUN is visible as offline not accessible. In Netapp, LUN is online and in Windows server, LUN is visible as two disks.

Can someone help me here to findout the root cause and fix it.

Regards,

Varaprasad

Re: LUN is offline in Windows 2008 R2

You can see it twice because you have two paths from the server to the storage. You need to install the DSM MPIO tools.

Re: LUN is offline in Windows 2008 R2

Thanks Gary for your prompt response. Is this because of multipathing, LUN goes offline in Windows? How could i make the LUN online on Windows??

Please suggest.

Varaprasad

Re: LUN is offline in Windows 2008 R2

You should be able to just launch disk manager -> Right click -> Online.

Re: LUN is offline in Windows 2008 R2

When i right click on LUN, all options are greyed out except "Properties". Even i could not create drive lettered disks (simple volumes) on the LUN from disk manegement.

Re: LUN is offline in Windows 2008 R2

Hi,

Microsoft has changed how SAN disks are handled by its Windows 2008 editions.

the default SAN policy is now VDS_SP_OFFLINE_SHARED for all SAN disks except the boot disk.

Here's the solution to this annoying problem:

DISKPART> san policy=OnlineAll

good luck,

Ariel

Re: LUN is offline in Windows 2008 R2

Thank you Ariel.

I have come across couple of issues while making a LUN online and accessible. Here is the issue and fix for my issue:

1. LUN created and assigned to a Windows host

2. On Windows 2008R2 OS, command prompt -> diskpart

    diskpart> SAN policy (Shows the SAN policy set as offline)

    diskpart> SAN policy=onlineall

    diskpart> SAN policy (Shows the policy available as online)

3. Rescan the disks from "DIsk Management" prompt and was able to view the LUN as disk.

4. Though disk was online this time, server stopped me from initializing the disk as disk property was set to Read-only

5. From "Diskpart>" prompt,

    diskpart> list disk (Lists all the disks availble on the server with numbers)

    diskpart> select disk n (Where n is the disk number you want to access)

    diskpart> attributes disk

    diskpart> attributes disk clear readonly

    diskpart> attributes disk Readonly option should be set to "NO" now)

6. From disk management, right click on the LUN (disk device) and select suitable option.

This clears my issue and enabled me to access the LUN from Windows 2008 R2.