Community

Subscribe
Highlighted

NFS Export - Root Access For All Hosts

I'm trying to configure an NFS Export that can be accessed by ALL HOSTS, with root access for all.  The "All Hosts" part is easy enough, but there doesn't seem to be a way to grant root access to every host.   I'm pretty sure that this is not possible via FilerView. 

How can I modify the /etc/exports entry so that it allows this?

This is what the current entry looks like.

/vol/MYVOLUME -sec=sys,rw,anon=0,nosuid

Re: NFS Export - Root Access For All Hosts

mikeymac1 wrote:

I'm trying to configure an NFS Export that can be accessed by ALL HOSTS, with root access for all.  The "All Hosts" part is easy enough, but there doesn't seem to be a way to grant root access to every host.   I'm pretty sure that this is not possible via FilerView.  Every host means you have selective hosts ? If yes, you can specify the IP addresses for those Host as Root via FilerView.

How can I modify the /etc/exports entry so that it allows this? Yes, you can always use command line for this. Look for the man_pages for 'exportfs' command.

This is what the current entry looks like.

/vol/MYVOLUME -sec=sys,rw,anon=0,nosuid

Re: NFS Export - Root Access For All Hosts

Providing the root access to all hosts is not a good idea but still if you want to do that, There is no wild character {*} supported by netapp exportfs i think, to give all host root access to a volume.You can use subnet option or

you can use Below mentioned options even using filerview..

      Host name
    *

      Host IP address
    *

      Netgroup
    *

      Subnet
    *

      DNS domain name

Re: NFS Export - Root Access For All Hosts

But will this setting in /etc/exports do the trick?

/vol/MYVOLUME -rw,anon=0

OR

/vol/MYVOLUME -anon=0

OR

/vol/MYVOLUME -sec=sys,rw,anon=0,nosuid

Here's the relevant portion of the ''exports" entry in the Data Ontap Command Reference:

We can illustrate the access rules thusly:

/vol/vol0 -anon=0

All hosts have

rw access, and root at that.

This seems pretty straight-forward.   Why can't I get this to work?