Subscribe

NFS datastore does not display "used space" capacity correctly

Hi, We have several datastores connected to our cluster (some iSCSI and some NFS volumes)

We have some as "Swap" volumes (these are all NFS volumes), where essentially we store the "swap" drives for the VMs. For some reason all the Swap volumes do not display the correct "used space" in the summary of the data volume in Virtual Center.

Also, when I check in Fast Veeam, I do see the actual spce that has been assigned to the swap drives and hence I know there is something wrong with the displayed value. For instance one of them has over 40Gb used but only displays 941.42Mb as the "used space".

This is very misleading especially when creating new VMs when we need to make sure there is enough available free space.

All the other volumes appear to display the correct 'used space' value. Any ideas why this is happening and how it can be corrected? Thanks in advance

Re: NFS datastore does not display "used space" capacity correctly

The VI Client does not auto-refresh NFS datastore sizes. Just right-click on a datastore and refresh it to get an updated view before deploying new machines.

Ultimately, I would recommend monitoring your NetApp storage utilization with the CLI or Filerview instead of the VI Client.

Re: NFS datastore does not display "used space" capacity correctly

As Nick mentioned, if it's the case that the VI client is not seeing the correct NFS datastore size, you can correct this by:

- waiting until the next time the VI client polls for the datastore size

- run the following command on one of the ESX consoles. "service mgmt-vmware restart" (the ESX server will go "grey" and then come back and you'll see the correct datastore size)

Cheers, Tony