Subscribe

No CIFS access although security permission for everyone is setting full

Hey Techis,

I have a problem with a cifs share.

I copied data from a unix security style qtree to a volume at a second filer which security style is NTFS only. We are working in a clean windows environment. So I created a CIFS share for that folder and Windows User everyone has full access like it is the standard method for a new share.

I can browse to some folders normally. But at some folders and subfolders I get an access denied. In the security options of the root folder I activated booth checks to replace the permissions in all subdirs.

But although I cant access the aforesaid folders.

With NetApp System Manager I can correctly browse to all folders when I wanna create an new share.

Hope you can follow my problem and my improvable English

Any ideas?

FAS2020, 7.2.4.L1

Thanks

Andi

Re: No CIFS access although security permission for everyone is setting full

The source files were from a volume with security style of UNIX. Should I read that these files are coming from an NFS/Unix system?

Might want to ensure that your new volume has create_ucode and convert_ucode options set to ON.

To troubleshoot access, you might also want to turn the cifs trace_login option to ON on the filer console. This will throw debug messages to the filer console upon CIFS access and generally provide good pointers to the problem.

>options cifs.trace_login on

HTH

Re: No CIFS access although security permission for everyone is setting full

Yes, right. These files are coming from an NFS/Unix filer.

First I set the create_ucode and convert_ucode options to ON. But didn't fixed my problem. Also I copied folder by folder to a new volume on the NTFS filer. Now everthing works fine.

I don't understand it right now....

Thnaks

Andi.

Re: No CIFS access although security permission for everyone is setting full

right,

so did you set the option that was suggested? the options cifs.trace_login on

If you did then try to map the folder and then have a look in /etc/messages files what the controller is telling you. you can

read the file like this;

rdfile /etc/messages

If you can post the error message here we can probably help. Another thing you can do to progress this is look at

<wcc> command

usermap.cfg file    which resides in /etc folder.

By look at the file I mean, look up on NOW how to use it. <wcc> will be good for troubleshooting

Eric

Re: No CIFS access although security permission for everyone is setting full

Probably it was ownership problem , you should to take ownership first on all folders from up , and than modify NTFS permissions

Re: No CIFS access although security permission for everyone is setting full

Yes it looks like folder level ownership problem. If your qtree security style is NTFS then you might need to check the ownership of the other folders which throws permission issue.

Thanks;

Daniel

Re: No CIFS access although security permission for everyone is setting full

Is this a windows based ation ? the action of changing the owner? Please confirm?