Subscribe

Openssh errors and warnings

Hello everyone,

while I'm connected to the filer, I see the following messages:

Wed Mar 7 10:20:28 CET [openssh.versionExchange.Fail:Error]: Did not receive identification string from [IP_ADDRESS].

Wed Mar 7 10:20:30 CET [openssh.dispatch.protocol:warning]: SSH dispatch failed from address [IP_ADDRESS], type 1, packet 5.

Does anyone know what this means and how to fix it?

Thank you in advance,

kind regards

Re: Openssh errors and warnings

This sounds a support related question.  We have external and internal subject matter experts in the NetApp Support Community answering questions.  If you have a NOW login you can ask in this area Filers.

Mike

Re: Openssh errors and warnings

It looks like something is trying to login using SSH that is not sending proper information.  Searching on "openssh.versionExchange.Fail:Error" provides a lot of software patches for devices monitored by SSH calls.

I don't suppose you are using a product called LogicMonitor?

This site refers to their product simply checking/monitoring SSH status, so it generates bogus SSH calls, just to get a reply.  Maybe you have a monitoring system that does the same thing?

http://help.logicmonitor.com/notes-for-monitoring-specific-types-of-hosts/netapp-filers/

- Scott

Re: Openssh errors and warnings

For anyone else that runs into this here is one possible solution: http://www.unixwitch.de/de/sysadmin/tools/netapp

Just disable the ServerAliveInterval on your ssh client for each of your filers since the filers don't seem to support it.

Do this by editing your .ssh/config in the client

Example:

# ~/.ssh/config

Host fas3240-a

     ServerAliveInterval 0

     Protocol 2

Host fas3240-b

     ServerAliveInterval 0

     Protocol 2

Host fas3240-c

     ServerAliveInterval 0

     Protocol 2

Host *

     ServerAliveInterval 2

     Protocol 2

Re: Openssh errors and warnings

Hummm, somehow this didn't work for me. Still looking for a solution

Re: Openssh errors and warnings

Changing the ServerAliveInterval was exactly the fix for the problem I was running into, but my warnings were a little different from the original poster:

Wed Jul 31 15:06:38 PDT [filername:openssh.dispatch.protocol:warning]: SSH dispatch failed from address [IP address], type 80, packet 191.

I log into a system that cuts off sessions after a short amount of time, so I had ServerAliveInterval set to 5 minutes on my Mac.  Unfortunately, this caused the NetApp to throw a warning on the console every 5 minutes when I was logged in.  I increased the interval and the console is *much* cleaner now.  Thanks!

.: Jared