Subscribe

Permission on exported NFS volume - problem ...

Hi, I have problem  perrmissions on the exported volume.

Volume security style is UNIX.

Two users with the same group write file to nfs share on your PC.

How to configure permissions on exported volume or storage to all users of the same group can read and write file or you can set permissions to all files saved as the same user ID and group ID ???

Best Regards

Pawel

Re: Permission on exported NFS volume - problem ...

Pawel:

The users are writing to the volume on a PC - is there a CIFS share on the volume, or is it mounted to the PC via NFS?

If they're writing via CIFS, the group the file inherits will be the users' NFS groups, either from the filer's /etc/passwd file, or NIS/LDAP, assuming that the usermapping is properly configured.  On the CIFS share, you can set the forcegroup option and/or one of the umask options, to ensure others can write to the files (again, with CIFS access).  If you set the umask to 002, files written will be group writeable, which means that any other user who maps to that same unix group will be able to overwrite the file.  If you set the forcegroup to whatever group the file gets written with, then everyone who connets will inherit that group, regardless of the group they actually connect to.

If they're writing over an NFS mount to the PC, whatever software is being used to facilitate that should have some sort of user/group/permissions configuration, which you'd have to mess around with.

Bill

Re: Permission on exported NFS volume - problem ...

Hi,

My all volumes is mounted to the PC (linux hosts)  via NFS.

Can I set umask 002 from the netapp storage on NFS share.

Now all files are saved with umask 022 so users who maps to the same unix group can not edit files one another.

Pawel

Re: Permission on exported NFS volume - problem ...

Pawel:

To the best of my knowledge, you cannot set the umask on the NetApp side for NFS shares.  However, from the Linux side you can set the umask of all the users in questions to 002 at login.

Bill

Re: Permission on exported NFS volume - problem ...

Thanks for all Bill

Pawel