Subscribe
Accepted Solution

Permissions issue on mounting share on Linux

I have created an NFS share on out NetApp for our DBA’s to test with. I have then gone into FilerView to export the share which was successful. I can mount the share successfully on a Windows machine, however the Linux guys are getting a ‘permission denied error’. Does anyone have any ideas of what may cause this?

Re: Permissions issue on mounting share on Linux

Hi,

check the qtree security.

It must be "unix":

qtree security /vol/*volumename* unix

And try again.

regards

Falk

Re: Permissions issue on mounting share on Linux

Hi,

There are a number of reasons why this can fail.  What do you actually mean my "I can mount it from a windows server"?  CIFS or NFS?

Read the manpage for exportfs and login to the filer.  'exportfs -c ip.addr.of.linux /vol/yourvol/yourqtree'  also with the "rw" and "root" flags.

Enable the options 'nfs.mountd.trace' and watch the messages log.

Make sure the reverse DNS of the linux servers works or use IP address in the exports file  (a working DNS is always a better plan).

Your life with NetApps will be infinitely easier in the long run if you use the cli instead of FilerView

Re: Permissions issue on mounting share on Linux

is there a way to do it without going into the CLI?

Re: Permissions issue on mounting share on Linux

Hi,

you can change the security style with the system manager:

Go to you filer -> Storage -> Qtrees. Select your Volume and click "Edit".

Since I had this error, I have a postit on my screen with "qtree security" :-)

best regards

Falk