Subscribe

VIF with VLANs containing mixed MTU

Apologies if this was covered in another thread.  Feel free to point me to that if that is the case.

I have a multimode LACP VIF.  Currently I have 2 VLANs (virtual interfaces) configured on it.  Everything is set to MTU1500.

vif1: flags=0xa2d08863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

vif1-2151: flags=0x2948863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

vif1-2157: flags=0x2948863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

We are about to enable jumbo frames on the swith, and I will be adding new VLANs (virtual interfaces) wich use MTU9000.

Just looking at ifconfig, the MTU of the VIF is 1500.  Does this matter?  If I add the new VLANs (virtual interfaces) with MTU9000, do I have to destroy and recreate the base VIF with MTU9000, or is that ignored and just the MTU of the VLANs (virtual interfaces) that matters?

vif1-2158 with mtu 9000 - being added

vif1: flags=0xa2d08863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500 - does this need to be destroyed and recreated with mtu 9000?

Thanks in advance.

Re: VIF with VLANs containing mixed MTU

What happens with the vlan using the default mtusize depends on your ontap version. Prior to ontap 7.3.3 changing the mtusize would change the mtusize for all vlans, which can result in connectivity issues. Unfortuately at the moment I can't find the document stating this.

I tested it some time ago with ontap 7.3.3P5 (no lcap though) on a test filer I have. 2 VLANs on a vif, changed 1 to mtusize 9000 and I was still able to access data using the VLAN with mtusize 1500 from a solaris host and nfs.

[edit]Found a NOW KB article regarding the ontap 7.3.3 support: https://kb.netapp.com/support/index?page=content&id=1010910[/edit]

Re: VIF with VLANs containing mixed MTU

Thank you, that was helpful.  I wish the language in the KB was a little less ambiguous as it states that it "could" happen, so I guess I will just have to find out for myself.