Subscribe

Windows 2008 Cluster - SnapDrive 6.1 - A security package specific error occurred

Hello all:

Windows admin here with light NetApp filer experience.

Both servers Windows 2008 Enterprise x64 SP1 with SnapDrive 6.1 installed.

Transport protocol is HTTP and running all services under a domain account and filers are part of the domain.

The cluster has been created and now trying to create the LUNs via SnapDrive out of volumes that were created last week by the SAN Admin.

Trying to start out with creating the shared disk for the Quorum so we can reconfigure.

When both nodes are online and you choose Create Disk in SnapDrive, presented with: SnpaDrive Error - Error: A security package specific error occurred

Not much more than this in the App Event logs either.

When you pause one node of the cluster you can connect fine via snapdrive but cannot create the shared disk because one node is offline.

Found a NetApp article but nothing helped.

Opened up a ticket with NetApp, but not much further along right now. Any suggestions?

Thanks,

Re: Windows 2008 Cluster - SnapDrive 6.1 - A security package specific error occurred

Is this Windows 2008 R2?

Re: Windows 2008 Cluster - SnapDrive 6.1 - A security package specific error occurred

No this is not Windows 2008 R2. At the end of my rope here

Re: Windows 2008 Cluster - SnapDrive 6.1 - A security package specific error occurred

A few things I could quickly think of.

- Firewall on all the nodes - Disable it and try.

- Is the SDW version the same on all the nodes?

Thanks,

~Satish

Re: Windows 2008 Cluster - SnapDrive 6.1 - A security package specific error occurred

Thanks Satish,

The Windows FW is disabled on both nodes and all software is at the same versions using the same domain account for the service account. The controllers are in the domain and this service account is on the local administrators on both nodes and the controllers.

The transport protocol is set to HTTP. Wondering if I should update the credentials to the service account I am using instead of a local account the SAN administrator provided during setup. The only reason I question that is because when one of the nodes is paused you can connect to the controller and run through the wizard, just can't create the LUN because both nodes aren't online. Once both of them are online and you right click and choose Create New disk, then we get the message above.

This is very weird.....

Re: Windows 2008 Cluster - SnapDrive 6.1 - A security package specific error occurred

I used to face this error during tests and it always used to be either the firewall on one of the nodes or the SDW version mismatch.

There's nothing else I can suspect at this time.

Thanks,

~Satish

Re: Windows 2008 Cluster - SnapDrive 6.1 - A security package specific error occurred

Thanks all for the responses.....Sorry for the late update. it turns out we had to create a new service account and assign an SPN to this account for SnapDrive to work correctly. We now use this new service account on all Windows2008/SQL2008 builds that are connected to NetApp storage and use SnapDrive. NetApp has since updated their internal documentation I believe. Appreciate it!

Re: Windows 2008 Cluster - SnapDrive 6.1 - A security package specific error occurred

Dear James,

We had similar problems on MS Exhange 2010. Could you please provide syntax to set SPN on each server?

Thank you.

Regards,