Subscribe

Windows 2008 R2 and snapshot directory

Hi,

Some of you may already bumped into this thread regarding Windows 7 & previous versions integration with NetApp snapshots:

http://communities.netapp.com/thread/4579

Bearing this in mind & the fact that w2k8 has a lot in common with Windows 7 I have configured my filer to use SMB2, so actually I can see previous versions properly on the host side. Well, almost properly - works fine on any share or directory, but no previous versions can be seen when a single file is right-clicked (still everything can be drag & dropped though when a previous version of folder containing this file is opened in new window).

OK, now the strange bit:

- Unit today I couldn't see snapshot directory on w2k8 host despite ticking the right box on the filer side, but I could at least browse into it by explicitly typing the path.

- Since today morning (after installing patches?) I can't see snapshot directory & I can't browse into it (path not found), yet previous versions still work fine, giving access to all snapshots. All settings on the filer side remain unchanged.

Has anyone seen this behaviour? (ONTAP 7.3.2, Win2k8 R2 64-bit std)

Regards,

Radek

Re: Windows 2008 R2 and snapshot directory

Check the following KB article.

https://now.netapp.com/Knowledgebase/solutionarea.asp?id=kb58356

Thanks,

Sharath

Re: Windows 2008 R2 and snapshot directory

Data ONTAP 7.3.2P6 and above should fix all the issues with previous versions tab in Windows 7.

For ~snapshot directory related issues, make sure that the following has set correctly.

1. Enable show hidden files option in windows folder options.

2. Enable "cifs.show_snapshot" option on NetApp filer.

3. Set "cifs.ms_snapshot_mode" option to "xp" on the filer.

Srinivas

Re: Windows 2008 R2 and snapshot directory

Hi,

Many thanks guys for your responses.

So far it looks like SMB session can access snapshot directory, but can't access previous versions, whilst it is exactly opposite with SMB2 session.

Regards,
Radek

Re: Windows 2008 R2 and snapshot directory

Hi,

W7 and W2K8 are using directory cache for displaying contents.

Try to set

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]

"DirectoryCacheLifetime"=dword:00000000

That should solve the issue

Thomas