"very old" SMB clients unable to access CDOT CIFS shares

Hi guys,


we recently migrated from 7-mode 8.1 to CDOT 9.1P8. Now we have issues with very old Linux/Irix/HP machines that they can't mount the CIFS shares via SMB. Errors are not really giving details on the client and the NetApp event log does not show errors either. E.g. at the IRIX I'm trying to access the share with smbclient 2.0.0 via "/usr/samba/bin/smbclient //ip/volume/qtree password -U user -W domain" and error says "session setup failed: code 0"  ... ok, I did a few adjustments on smbclient and also tried to create a local SVM user to use for connection without success.


Then I've tried all possible vserver CIFS volume options and vserver cifs security options, tested after each change again without success. But when I disable SMB1 at least I'm then getting an error at client and NetApp event log.


Am I missing something, or is my new NetApp just incompatible with "very old" SMB version? Created a new vfiler on the old 8.1 NetApp - no issues.


Any help/advise appreciated Smiley Happy


many thanks,


Re: "very old" SMB clients unable to access CDOT CIFS shares

Hi there,


CIFS/SMB implementation and security requirements have changed a fair bit since Samba 2.0.0 was released in 1999 - but generally options can be changed to enable access from older clients, although there are often security and privacy trade-offs necessary.


First step would be to work through our CIFS authentication troubleshooting guide at and then review some of the articles at


Hope this helps!