Re: API-Service 1.2 install problem

What OS are you running?


I tried Centos7, working on Trying RHEL 7 Now. (Just got our License Info)



Re: API-Service 1.2 install problem

Hi @cladkinsmtu,


I'm using RHEL7 - version 7.3.


regards, Niels

Re: API-Service 1.2 install problem

[ Edited ]

I was unable to find a short and clean "do over" method to cleanly remove the corrupt netapp-platform-base and get MySql 5.6.35 installed without getting the same or similar errors. But a complete "do over" (burn and rebuild the VM) with my own improvised set of steps finally got it working with MySQL 5.6.35 ... at least the OnCommand-API-Service-1.2P1.bin script ran to completion. 


FWIW, my OS was RHEL 7.1

Re: API-Service 1.2 install problem

Uninstall per the manual - (yum remove ocie-serverbase) and reinstall per the manual (./OnCommand-API-services-1.2.0x.bin). Had the same issues as you with mysql-5.6.36. Had to downgrade to 5.6.35 but the API-Service install was hosed.

Re: API-Service 1.2 install problem

[ Edited ]

So I personally had a few problems with my server build, so I needed to re-install from scratch.



Fresh Centos 7 box, 



2 Disks


1 OS (50GB)

1 NetApp/Data (100GB)



The Gist of It:



Disable All Versions except the 5 repo on Mysql after installing Community Repos



Set selinux to permissive (opposite of what install doc says)

-could have just set the Selinux ACLS on the /opt/netapp dir.



Go and install mysql 5.6.35 (or later but not the latest version)

-Mysql Community Commons

-Mysql Server 


Once done, go add a glob to your yum.conf to disable all MySQL Versions (The install script will be able to continue with the currently installed version, and the version is LOCKED from this point on.)


Once done, you can now proceed to install the OnCommandAPI system.


After 1 week of fighting with it, I found out we were going in a different direction without the OnCommandAPI . (Going SDK Route)



Feel free to reply if you need more detailed instructions on fixing it, and what worked for me.










Re: API-Service 1.2 install problem

Thanks to everyone who helped out here. This is not the sort of effort  most developers find fun. I spend only about about 3% of my time on Linux/UNIX admin (unless you count macOS). My UNIX training was back in the 1990s so I always stumble through all the new (to me) stuff like SE Linux, RPMs, yum, and all this other new stuff. Back in the 90s the goal was to figure out how to package and ship a product that could run on AIX, Tru64, Solaris or HP-UX. It never happened. Linux on x86 / x64 will solve world hunger they promised. Pppfft. I think it's gotten worst (look how yum screwed us in this case).


The goal needs to be to make installing a server app as easy as I can install an app on my iPhone. Ha! I guess if API-Services was was a container provisioned onto a container-aware hypervisor ... that world solve world hunger. Pppfftt, probably not. 


PS: I did get it working finally and my next step was installing the WFA API-Services Pack into my WFA environment. That was actually easy and I was able to install it, build, and test a dirt-simple WFA workflow in just an hour or two. So my multi-day struggle with API-Svcs paid off. I just hope by the time I have to update my API-Services it's offered as a vApp or container or something easier to deploy.