Subscribe

Add volume to dataset

I have a workflow that creates a primary volume, a secondary volume and a snapmirror relationship and then use the Add volume to dataset command to put the volume into an existing dataset.

The workflow works in preview mode but fails on execution

The dataset has a protection policy attached and if I import an existing SM relationship it works fine.

When adding the volume to the dataset I get the following error.

Error: Could not add EUKSBNETAPP02.endemoluk:/Arch_DanTest1115 to dataset EUK_Archive (4324). Reason: There is no volume, qtree, directory, host, aggregate or virtualization object named 'EUKSBNETAPP02.endemoluk:/Arch_DanTest1115'.

The volume does get created, so it does exist.

Has anyone come across this before, or know where I can find additional info on the error to help troubleshoot

Regards,

Frequent Contributor

Re: Add volume to dataset

Hi Dan,

Let me try and help you out here.

Can you tell me what version of WFA you are running?

Can you attach the workflow?

Looks like an issue in the way you have provided inputs somewhere.

-Anil

Re: Add volume to dataset

Hi Anil,


That is very probable as this is my first workflow.

I am using 2.1.0.70.32

Please see attached for workflow

Regards, Dan.

Frequent Contributor

Re: Add volume to dataset

Thanks Dan,

I am trying to reproduce your issue.

Can you send me the logs as well?

Go to Administration>Log Viewer.

I just need Wfa.log.

Regards,

Anil

Re: Add volume to dataset

Hi Anil,

I have attached logs.

Regards, Dan

Frequent Contributor

Re: Add volume to dataset

Hi Dan,

I figured out the problem.

The volume is created alright but when you try to add the volume to the dataset, turns out DFM has not yet acquired the volume from the filer. Therefore it does not know about the newly created volume you are talking about.

I tried a simpler workflow on my setup and i was able to reproduce it. Check the attached snapshot.

Now what you have to do is, wait for dfm to acquire from ONTAP before adding the volume to the dataset.

To do this, there is a command "wait for monitor refresh" that needs to be added before "add volume to dataset" command.

I do not have a 2.1 setup right now. Otherwise i would have made the necessary changes for you.

Please let me know if you need help with using that command in your workflow.

-Anil

Re: Add volume to dataset

Hi,

You can also additionally refer to the sample workflow which will be available in 2.1 system:

"Create a new Volume in a Dataset and Wait for object discovery" to see how to use the command "Refresh monitors on array" and "Wait for monitor refresh" as per the suggestion above.

Thanks,

Shailaja

Re: Add volume to dataset

Also if your DFM is 5.x C Mode, then there isn't any WFA certified command for Refresh Monitoring samples and Wait for refresh. Attaching those here which I made some months back. Import this Workflow .dar and you'll get the 2 commands.

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Add volume to dataset

Hi Anil

Apologies for not updating this earlier, I have been tied up on other things.

I have added the "wait for monitor refresh" and upped the timeout value, but I still get the same issue.

I have attached my workflow/logs so you can see what I have done.

Regards, Dan.

Re: Add volume to dataset

Dan, I imported your workflow and I see that you have added only the Wait for Refresh cmd. Only Wait fo Refresh is NOT enough. See Shailaja's reply above. You need to Add 2 commands

1. "Refresh monitors on array"


followed by


2. "Wait for monitor refresh"

Attaching the workflow with corrections. There is another parameter $OCUM_server ( i.e. DFM) that you need to provide now at workflow execution.

sinhaa


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.