Community

Subscribe
Highlighted

After downgrading 8.1.2 to 7.3.7P1, can't login into my controller via OnCommand SM.

After downgrading 8.1.2 to 7.3.7P1, I can't fully login into my controller via OnCommand System Manager: system info on the right is showing, but the left panel remains empty. Ath e time of login attempt the following message is printed to syslog:

[api.input.invalidSchema:warning]: Error in API input schema validation. API name: disk-list-info. Detailed error: Extra input: ownership-type.

Can this be the cause of login failure? Any ideas for fixing it?

--Leon.

Re: After downgrading 8.1.2 to 7.3.7P1, can't login into my controller via OnCommand SM.

Did you delete all of the snapshots? (part of the procedure to revert from 8.x back to 7.3.x).

Re: After downgrading 8.1.2 to 7.3.7P1, can't login into my controller via OnCommand SM.

Humm,

Can you try to delete your controller from Oncommand system Manager and re-eiscover it, for the moment I think Oncommand System Manager want an DOT 8 version

Re: After downgrading 8.1.2 to 7.3.7P1, can't login into my controller via OnCommand SM.

1. Check the compatibility of System Manager release and Ontap Version

2. Recreate the SSL/SSH certificates on the controller (secureadmin setup ...)

Maybe this helps,

Peter

Re: After downgrading 8.1.2 to 7.3.7P1, can't login into my controller via OnCommand SM.

Hi Leon

Try to clear all IE cached data:

TOOLS --> INTERNET OPTIONS --> BROWSING HISTORY --> DELETE

Perhaps this helps

regards

Thomas

Re: After downgrading 8.1.2 to 7.3.7P1, can't login into my controller via OnCommand SM.

Thank you to everybody for your suggestions.

Deleting the browser's cache didn't work (I am using Firefox18).

ONTAP and OnCommand SM versions are compatible.

All snapshots were deleted AFAIK (There are clear error messages telling one which snapshots have to be deleted for downgrading to proceed).

I removed the system from OnCommand SM and... can't re-discover it anymore.

I guess, ssl/ssh certificates are relevant for the login but not for the discovery.

Sure I've exited and logged in into OnCommand SM.

What else could one try?

There is on interesting moment. Namely, the controller itself ("snap list" command) reports that there are only post-downgrading (later than March 3) snapshots, yet the admin host finding pre-downgrading directories and files.

On the controller:

gen-netapp2> snap list vol_10gb

Volume vol_10gb

working...

  %/used       %/total  date          name

----------  ----------  ------------  --------

  0% ( 0%)    0% ( 0%)  Mar 07 12:54  gen-netapp5(0118050929)_vol_10gb_m.2203 (snapmirror)

  0% ( 0%)    0% ( 0%)  Mar 07 12:00  hourly.0

  0% ( 0%)    0% ( 0%)  Mar 07 08:00  hourly.1

  0% ( 0%)    0% ( 0%)  Mar 07 00:00  nightly.0

  0% ( 0%)    0% ( 0%)  Mar 06 20:00  hourly.2

  0% ( 0%)    0% ( 0%)  Mar 06 16:00  hourly.3

  0% ( 0%)    0% ( 0%)  Mar 06 12:00  hourly.4

  0% ( 0%)    0% ( 0%)  Mar 06 08:00  hourly.5

  0% ( 0%)    0% ( 0%)  Mar 06 00:00  nightly.1

On the admin host:

[root@vh13 .snapshot]# pwd

/netapp2/vol_10gb/.snapshot

[root@vh13 .snapshot]# ls -l

total 36

drwxr-xr-x  5 root root 4096 Mar  6 15:19 gen-netapp5(0118050929)_vol_10gb_m.2204

drwxr-xr-x  5 root root 4096 Mar  6 15:19 hourly.0

drwxr-xr-x  5 root root 4096 Mar  6 15:19 hourly.1

drwxr-xr-x  5 root root 4096 Mar  6 15:19 hourly.2

drwxr-xr-x  5 root root 4096 Mar  6 15:19 hourly.3

drwxr-xr-x  5 root root 4096 Mar  6 11:42 hourly.4

drwxr-xr-x  5 root root 4096 Feb 26 10:32 hourly.5

drwxr-xr-x  5 root root 4096 Mar  6 15:19 nightly.0

drwxr-xr-x  5 root root 4096 Feb 26 10:32 nightly.1

[root@vh13 .snapshot]#

[root@vh13 .snapshot]# ls -l hourly.5

total 501136

drwxrwxrwx  2 root root      4096 Feb 27 07:27 qt_10gb

drwxrwxrwx  2 root root      4096 Feb 27 07:31 qt_10gb_2

drwxrwxrwx  2 root root      4096 Feb 28 07:57 qt_10gb_3

-rw-r--r--  1 root root    102400 Feb 26 10:56 urandom100kb

-rw-r--r--  1 root root     32768 Feb 26 10:32 urandom32kb

-rwxr-xr-x  1 root root 512000000 Feb 26 11:36 urandom500mb

Re: After downgrading 8.1.2 to 7.3.7P1, can't login into my controller via OnCommand SM.

OK. It looks like there are conflicting accounts of 7.3.7P1 compatibility with OnCommand SM 2.0.2. In the latter's release notes it says:

Your storage systems must be running any of the following versions of Data ONTAP:

  • Data ONTAP 7G (starting from 7.2.3)

Yet the Interoperability Matrix Tool shows for OnCommand SM 2.0.2:

....

NetApp Data ONTAP 7.3.5.1

NetApp Data ONTAP 7.3.6

NetApp Data ONTAP 8.0 7-Mode

...