Subscribe
Accepted Solution

Agent Address = 127.0.0.1

Hi all,

I configured both my OC & Sim to send traps to my computer.

The traps sent by the storage system show up with the correct "Agent Address" value (aka the IP of my sim)

The traps sent by OnCommand only show 127.0.0.1 in the Agent Address field

is there a way to configure OnCommand to send the right value.? (aka the DFM Server IP address)

thanks for your help

Re: Agent Address = 127.0.0.1

Hi yweisser,

I tried on my OnCommand 5.0 & Trap receiver setup and I could receive traps with correct IP address as that of the DFM server.

Was just curious if you are running the trap receiver/listener on the same server as that of the DFM server(sorry for raising not so likely possibility, just wanted to confirm)?

Thanks,

-Amir

Re: Agent Address = 127.0.0.1

Hi Amir,

My OnCommand in on a Centos VM on my laptop, whereas my TrapReceiver is on my laptop (regular Windows7 session)

br

Re: Agent Address = 127.0.0.1

Hi yweisser,

This is the similar setup that I am also testing with. What kind of VM networking have you configured? Host Only/NAT/Bridged?

With which address you are able to ping from OnCommand VM to your laptop(physical) and vice-versa?

Thanks,

-Amir

Re: Agent Address = 127.0.0.1

my VM in configured with NAT

=> IP 192.168.204.129/24 (Ethernet adapter VMware Network Adapter VMnet8)

my computer is seeing on the 192.168.60.1/24 network (Ethernet adapter VMware Network Adapter VMnet1)

they can both communicate since:

- I use the OnCommand GUI from my laptop

- the NMC is installed on my laptop

- I receive traps (it s just the IP address that come out weird...)

by the way, what are the values of the following option on your environment: dfm option list localHostName

br

Re: Agent Address = 127.0.0.1

I think I got it:

I set the option localHostName to the value I wanted (ie the IP Address), & it s now correctly displayed in my TrapReceiver

thanks for your help

y

Re: Agent Address = 127.0.0.1

Good to know that its resolved! However i think the issue more due to the NAT configuration you have because even in my case the option is not set and I can still the correct IP address of DFM server:

[root@oncommand ~]# dfm option list localHostName

Option          Value

--------------- ------------------------------

localHostName

Probably after setting this option SNMP traps are generated with this value rather than carrying the NAT address(which is also localhost in your case) as it was happening earlier.

Thanks,

-Amir