Subscribe

Attempting to install OCUM 6.4P4 on CentOS 7.2 / RHEL 7.2

[ Edited ]

Hi, running into these problems when trying to install OCUM. I know Centos isn't technically supported, but I want it to work. Also getting stuck on my RHEL install though (maybe since it's 7.2?)

 

So after installing the required java version of at least 1.8.0.71, I'm getting stuck:

 

 

CentOS:

 

yum install *.rpm --assumeno

---> Package ocie-serverbase.x86_64 0:1.3.0-2016.09.2066 will be installed
--> Processing Dependency: java-1.8.0-oracle >= 1:1.8.0.71 for package: ocie-serverbase-1.3.0-2016.09.2066.x86_64
--> Finished Dependency Resolution
Error: Package: ocie-serverbase-1.3.0-2016.09.2066.x86_64 (/ocie-serverbase-1.3.0-2016.09.2066.x86_64)
Requires: java-1.8.0-oracle >= 1:1.8.0.71
java -version
java version "1.8.0_101"

 

RHEL:

 

---> Package ocie-serverbase.x86_64 0:1.3.0-2016.09.2066 will be installed
--> Processing Dependency: java-1.8.0-oracle >= 1:1.8.0.71 for package: ocie-serverbase-1.3.0-2016.09.2066.x86_64
--> Finished Dependency Resolution
Error: Package: ocie-serverbase-1.3.0-2016.09.2066.x86_64 (/ocie-serverbase-1.3.0-2016.09.2066.x86_64)
           Requires: java-1.8.0-oracle >= 1:1.8.0.71
java -version
java version "1.8.0_102"

 

So it's basically the same thing. What gives? My java should be fine, shouldn't it?

Re: Attempting to install OCUM 6.4P4 on CentOS 7.2 / RHEL 7.2

What Java package did you install?

 

You may have installed the right version but have you installed the right package?

 

what does :

 

yum list java*

 

come back with?

Re: Attempting to install OCUM 6.4P4 on CentOS 7.2 / RHEL 7.2

nothing on my Centos box (installed rpm manually), on RHEL shows this:

 

$ yum list java*
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/product/rhui-client-config-server-7.crt
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/rhui-client-config-server-7.key
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/product/content-rhel7.crt
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/content-rhel7.key
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/product/content-rhel7.crt
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/content-rhel7.key
Could not contact CDS load balancer rhui2-cds01.us-east-1.aws.ce.redhat.com, trying others.


Could not contact any CDS load balancers: rhui2-cds01.us-east-1.aws.ce.redhat.com, rhui2-cds02.us-east-1.aws.ce.redhat.com.