Subscribe

CF Takeover Question

I have a single 2040 with dual controllers (heads)

I think my failover is not working. When I type in the commands below, I do not receive the partners IP Address, but I do the the lo UP.

CF Takeover

ifconfig -a (shows UP)

Partner

ifconfig -a (shows same)

Partner (to logoff)

CF Giveback

I heard in order to confirm that this is working, I must see the other heads IP Address when doing an ifconfig -a

Can someone clue me in as to how to properly test failover?

CF Enable is enabled on both controllers and sysconfig does show Partner ID as well.

Re: CF Takeover Question

Sounds like you have no "partner" setting on the interfaces...

can you provide the ifconfig lines from both nodes, please?

Peter

Re: CF Takeover Question

You need to tell for every interface over which partner interface should traffic go in takeover. It is done by “partner” argument of ifconfig. You can find detailed description in normal documentation.

It would help if you provided output if ifconfig –a on both heads and told which exactly interface(s) should be taken over.

It was always possible to specify either partner interface name or partner IP address, but I have heard that recent releases support only interface name.

CF Takeover Question

So controller failover is not operational by default? Well I did clear the configuration (OS) maybe that had something to do with it. I just thought this would happen automatically. I don't have the ifconfig -a output because it's on a private network unless I pencil it all down and type it in. If there is specific output you need let me know and I can assist.

So I need to specify what partner will failover with the ifconfig partner argument? I'll try and get more details later.

CF Takeover Question

Yes it is not built automagicaly....

the lines in /etc/rc should read like similar to this, if you have ethernet ports without redundancy (VIF, IFGRP):

ifconfig e0a `hostname`e0a netmask 255.255.252.0 partner e0a mtusize 1500 trusted -wins up

ifconfig e0b `hostname`e0b netmask 255.255.255.0 partner e0b mtusize 1500 trusted -wins up

this configures to failover the local e0a interface config on the partner on port e0a (partner e0a) and the same for e0b...

Of course this need to be done on both nodes.

If you use VIF (Ontap7) then it could read like this:

vif create lacp vif0 e0b e0a

vif create lacp vif1 e0e e0d

ifconfig vif0 `hostname`-vif0 netmask 255.255.252.0 partner vif0 mtusize 1500 trusted -wins up

ifconfig vif1 `hostname`-vif1 netmask 255.255.255.0 partner vif1 mtusize 1500 trusted -wins up

this configures to failover the local vif0 interfacegroup config on the partner interfacegroup vif0 (partner vif0) and the same for vif1...

When running Ontap8 just replace alll the "vif" with the new command "ifgrp".

Hope this makes the config clear.

Peter

CF Takeover Question

hi there,

Just a piece of advice here: Peter is not wrong in what he is saying however be careful in copying his suggestion as he is using

LACP in his VIF settings. If your switches dont support LACP then that wont work for you. IN that case you should use

<single> or <multi>.

Furthermore make sure your RC file gets modified accordingly to what you end up using. Finally, the best way to test

this is before the controllers go into operational mode, during setup. I would set it up and then pull cables to see when/how

failover works according to your setup. I appreciate it might be late for you, but if not, do test your settings by pulling network

cables, turning switches off, rebooting etc.

Cheers,

Eric

CF Takeover Question

hi,

you can configure the partner interfaces over the filers webgui. there you can choose network options, your vif or interface you want to be takeover and modify.

there you have a field for your partner interface.

regards

jakob

CF Takeover Question

Peter, Eric and Jacob,

Thanks guys, I'll see if I can do it over FilerView first and then look at my RC file later.

Remember that the 2040 has both controllers in a single unit. I'm using 8.0.1 OnTap. I find this odd that they make you do this to enable failover of the controllers. Also, my interfaces are e01,e02 not e0d I think that was for another unit. But I see what you're saying. I'll give it a try and report back.