Subscribe

Can't join RedHat IDM Domain

OnCommand 9.0, trying to join an NFS SVM to the RedHat 7.2 IDM Domain and it's failing saying the SPN already exists, which it absolutely doesn't.  Just brought up this IDM domain so nothing is joined to it yet.

 

I've tried renaming the SVM and joining it with a new name, still get the same SPN already exists failure.  We can't do autoFS of user home directories without it joined to the domain supposedly.  Any ideas?  Thanks!

 

 

la-6pna01::vserver nfs> kerberos-config modify -vserver la-6pnasvmnfs03 -lif la-6pnasvmnfs02_nfs_lif1 -kerberos enabled -spn nfs/la-6pnasvmnfs03.internal-idm.domain.com@INTERNAL-IDM.DOMAIN.COM -admin-username mdadmin

Password:

Error: NFS Kerberos bind SPN procedure failed
[ 0 ms] Creating account in Unix KDC
[ 43] Successfully connected to ip 10.85.128.8, port 749 using
TCP
**[ 52] FAILURE: Unexpected state: Error 1142 at
** file:src/utils/secd_kadmin_utils.cpp
** func:createVifKrbAccountUsingKadmin line:219
**[ 52] FAILURE: spn already exists. Failed to reuse spn
** 'nfs/la-6pnasvmnfs03.internal-idm.domain.com@INTER
** NAL-IDM.DOMAIN.COM' using admin spn
** 'mdadmin@INTERNAL-IDM.DOMAIN.COM', error: Unknown
** code 0
[ 53] Uncaptured failure while creating account

Error: command failed: Failed to enable NFS Kerberos on LIF
"la-6pnasvmnfs02_nfs_lif1". Failed to bind service principal name on LIF
"la-6pnasvmnfs02_nfs_lif1". cifs smb kadmin error.