Community

Subscribe
Highlighted
Accepted Solution

Can't see any other database schema besides information_schema

I'm using WFA 2.0.1 and when I connect to the database using MySQL workbench 5.2, I can only see the information_schema.  I used the user wfa and blank password to connect.  I was hoping to view the tables so I could write some custom filters and possibly use the playground schema.  What am I doing wrong?

Re: Can't see any other database schema besides information_schema

Please use username/pwd wfa/Wfa123 to access playground DB.

You can refer to the workflow developers guide for more details

https://library.netapp.com/ecm/ecm_download_file/ECMP1307539

Section "What playground database is".

-Abhi

Re: Can't see any other database schema besides information_schema

The doc says WFA 2.1 and I'm using 2.0.1, will this info still apply?

Re: Can't see any other database schema besides information_schema

Yes

-Abhi

Re: Can't see any other database schema besides information_schema

using user wfa and password Wfa123 it tells me access denied.

Re: Can't see any other database schema besides information_schema

jrpatrick,

      going back to your original problem, can you answer the following?

1. Is it an absolute new installation of WFA and your WFA is completely fresh?

2. When you were able to see only the information schema, what credentials were you trying?

3. Credentials wfa/Wfa123 work only when server address is localhost. By default remote DB login is disabled. You can enable it, by following

  1. Edit 'NetApp\WFA\mysql\my.ini'
  2. Comment the last line - "bind-address=localhost" to "#bind-address=localhost"
  3. Save the file and close.
  4. Restart the WFA Database Service.

Re: Can't see any other database schema besides information_schema

1. Is it an absolute new installation of WFA and your WFA is completely fresh?

I think this system had version 1.1 on previously. It was removed and 2.0 installed.

2. When you were able to see only the information schema, what credentials were you trying?

userid:wfa password: blank

3. Credentials wfa/Wfa123 work only when server address is localhost. By default remote DB login is disabled.

I have mysql workbench installed on the wfa server so all the communications I have been doing is via localhost. 



Re: Can't see any other database schema besides information_schema

I can now only see that you have been hit by a known bug whose cause is somewhat unknown. It happens on some rare occasions ( outside of netapp,  you have been the first case I know )  where even after a successful installation, WFA schema tables are not created.

The only way out is to uninstall this WFA and re-install. Its should work after that given the rarity of the bug's occurrence.

Your inconvenience is regretted.

Also I suggest you can use WFA2.1 version instead of WFA2.0. Its a big jump from 2.0 to 2.1

Re: Can't see any other database schema besides information_schema

Created a brand new VM, installed 2.0.1 on it, and still have the same issues.

Re: Can't see any other database schema besides information_schema

Hi Jrpatrick,

Just to confirm several points:

1) You have created a new VM (Which OS), installed 2.0.1 (No occupied ports right?)

2) Did you try and access WFA DB directly after installation?

3) Did you restore your backup and then tried?

4) Are you accessing the DB locally or remotely? Since remote access was not available by default.

If you restored a backup prior to trying access - I suspect something in the backup is amiss.

If not - Would be very interesting to see your backup.

Can you share it here or send it directly to yaronh ** @ ** netapp.com  (Please remove asterisks).

Thanks,

Yaron