Subscribe
Accepted Solution

Clone Volume fails with WFA 4.1RC1

I have a workflow that stopped working after upgrading to WFA 4.1RC1. The built-in "Clone volume" command is aborted with error message "Extra input: junction-path". To get the other parts of the workflow out of the equation, I wrapped this command in a minimal workflow with static selection of all user inputs. The error message was still there. Are there any known issues in this version?

 

14:43:28.692 ERROR  [Clone volume] Extra input: junction-path
14:43:28.785 ERROR  [Clone volume] Command failed for Workflow 'Clone LAB Volume' with error : Extra input: junction-path

 

Preview works fine - the error is only encountered during execution.

 

ONTAP 9.1 is used with OCUM 7.1 as data source.

 

Re: Clone Volume fails with WFA 4.1RC1

Hi Richard,

 

This is a issue with Powershell tool kit. We already have  burt for this.

Please create a clone without providing the junction path. It will work.

 

Regards,

Sundar

Re: Clone Volume fails with WFA 4.1RC1

Good to hear that it is a known issue. Is there a fix in a near future? It would be good if a fix would be bundled with WFA 4.1GA to avoid production environment impact.

 

I already made a copy of the Clone Volume command with Mount-NcVol as a separate step after cloning the volume. Works fine.

 

Re: Clone Volume fails with WFA 4.1RC1

Issue is observed in cdot 1.0.0 & 1.2.2 as well.

This is a issue with tool kits. we have already raised the burts (BURT ID's: 1070446 , 1071322)
Once, we get the update from tool kit team, we will fix these issues .

Re: Clone Volume fails with WFA 4.1RC1

@Richard

 

making a copy and replacing it in your workflow is NOT required. There is a command "Mount Volume' already available which can work for you and.

 

And this should continue to work seamlessly even when the fix is available.

 

 

So in your workflow, add this command next to the 'Clone volume' command.

 

In 'Parameters for Mount Volume' Select doopdown 'Using a previously defined volume'. 

 

Now select the volume defined as 'Clone' in 'Clone Volume' command.

 

In tab 'Other Parameters' parameter Juntion_path is available for you.

 

That's all done.

 

 

See the image below to help you.  

 

Clone Volume

 

Clone_vol_and_mount.png

 

Mount Volume

 

Clone_vol_and_mount1.png

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Clone Volume fails with WFA 4.1RC1

I guess I would then have to change the Error Action of the Clone Volume step, as it aborts the workflow when the junction flaw is encountered?

Re: Clone Volume fails with WFA 4.1RC1

@Richard

 

Chaging Error action to Continue or SilentlyContinue is not going to change anything. The cmdlet is executed using Invoke-Expression and won't matter here.

 

I suggest use the method I told you. Add a new command 'Mount Volume' remove the junctionpath parameter to this command. Thats all.

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Clone Volume fails with WFA 4.1RC1

Ok, I realize I didn't read all details. Leaving the Junction field empty bypasses the bad code line - that makes sense. I do not have time to verify it right now but I do not see any reason why it should not.

 

Thank you for your assistance!