Subscribe

Cluster Lacks Spare Disks

I have recently deployed several 2552 Clusters that are getting an error in OnCommnand Unified Manager that they lack spare disks.  

 

 

THe config is 2552 20*900 GB SAS + 4*400GB SSD

 

I am using ADP

 

Storage pool contains either 3 SSD with 1 spare or 4 SSD I have tried both

 

Then there are 2 aggregates 9*900GB SAS with 1 spare disk each.    

 

If I run aggregate show-spare disks I get this output where I have all 4 ssd in the storage pool

 

 

aggregate show-spare-disks
  (storage aggregate show-spare-disks)

Original Owner: akl-shha030479
 Pool0
  Partitioned Spares
                                                            Local Local
                                                             Data Root Physical
 Disk Type RPM Checksum Usable Usable Size Status
 --------------------------- ----- ------ -------------- -------- -------- -------- --------
 1.0.23 SAS 10000 block 775.3GB 61.58GB 838.4GB zeroed

Original Owner: akl-shhb030479
 Pool0
  Partitioned Spares
                                                            Local Local
                                                             Data Root Physical
 Disk Type RPM Checksum Usable Usable Size Status
 --------------------------- ----- ------ -------------- -------- -------- -------- --------
 1.0.22 SAS 10000 block 775.3GB 61.58GB 838.4GB zeroed
2 entries were displayed.

 

 

 

 

and this output where I have a spare SSD

 

  aggregate show-spare-disks
  (storage aggregate show-spare-disks)

Original Owner: bwu-shha030473
 Pool0
  Spare Pool

                                                           Usable Physical
 Disk Type RPM Checksum Size Size Status
 --------------------------- ----- ------ -------------- -------- -------- --------
 1.0.3 SSD - block 372.4GB 372.6GB zeroed

Original Owner: bwu-shha030473
 Pool0
  Partitioned Spares
                                                            Local Local
                                                             Data Root Physical
 Disk Type RPM Checksum Usable Usable Size Status
 --------------------------- ----- ------ -------------- -------- -------- -------- --------
 1.0.23 SAS 10000 block 775.3GB 61.58GB 838.4GB zeroed

Original Owner: bwu-shhb030473
 Pool0
  Partitioned Spares
                                                            Local Local
                                                             Data Root Physical
 Disk Type RPM Checksum Usable Usable Size Status
 --------------------------- ----- ------ -------------- -------- -------- -------- --------
 1.0.22 SAS 10000 block 775.3GB 61.58GB 838.4GB zeroed
3 entries were displayed.

 

 

Both of which I think should be fine, but I get a cluster lacks spare disks for both of these clusters in OCUM .   I am running OCUM 7.0RC1

 

Re: Cluster Lacks Spare Disks

Hi,

 

It could be because of bug 908898 False spares low warning for RAID4 storage pools with 1 SSD for the HA pair.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Cluster Lacks Spare Disks

I thought this also but I get the error for Both nodes in the cluster and It clears on occasion

 

Re: Cluster Lacks Spare Disks

I have the same issue on 3 of my 5 clusters.

They all have spares configured but I still get the warnings.

Occassionally the warning in OCUM will go away only to return several days later.

 

The issue has gotten worse since upgrading 4 of the 5 clusters to ontap 9.1P5 and OCUM to 7.1P2.

Used to only get the warning on 1 cluster node which was a legit warning.

Now I get it on 4 nodes across 3 clusters.