Subscribe

DFM Performance Report missing data in fields for some Controllers

Hi,

I'm trying to generate a perfomance report from the DFM cli using the following command:

dfm report view -F csv -P 1w storage-system-NAS-performance-summary

Some of the controllers in the report are only returning the 'Controller Name' and 'Model' fields.

e.g.

dfm report view -F csv -P 1w storage-system-NAS-performance-summary
Could not set core rlimit to infinity.
"Object ID","Type","Status","Storage System","Model","CPU Busy (%)","CIFS Ops/Sec","CIFS Latency (millisec)","NFS Ops/Sec","HTTP Ops/Sec","NFSv3 Read Latency (millisec)","NFSv3 Write Latency (millisec)","NAS Throughput (KB/Sec)"
133,Active/Active Controller,Normal,filer1,FAS6080,48.66,3.60,1.58,4082.84,0.00,1.48,1.12,38803.12
132,Active/Active Controller,Normal,filer2,FAS6080,44.41,111.75,0.35,13069.95,0.00,0.47,0.21,32050.73
11269,Active/Active Controller,Normal,filer3,FAS6080,,,,,,,,
11267,Active/Active Controller,Normal,filer4,FAS6080,,,,,,,,

 

Any ideas why a report would not seem to run for some controllers in a DFM instance?

Re: DFM Performance Report missing data in fields for some Controllers

Sorry found the answer it out soon after posting! :S

 

dfm diag was failing the Performance Advisor checks:

 

Performance Advisor Checklist
perfAdvisorEnabled     Passed
hostType               Passed
hostRevision           Passed
hostLogin              Passed
perfAdvisorTransport   Failed (perfAdvisorTransport set to httpOnly, but host uses https)

 

changed the perfAdvisorTransport=httpsOK from httpOnly as per advice from thread below:

 

http://community.netapp.com/t5/OnCommand-Storage-Management-Software-Discussions/DFM-perfAdvisorTransport-set-to-httpOnly-but-host-uses-https/td-p/420...

 

Thanks