Subscribe

DFM/Provisioning Manager connectivity problem

Provisioning Manager -

My DFM is in one subnet (DEV), my system (where I'm trying to run provisioning manager console) is in another (PROD), and the array is in another (PROD).

There may be ACLs between all three areas.

Basically, when I use provisioning manager on an array in DEV, where DFM is running, it works.

When I try to provision to a resource pool in TEST (in the PROD subnet), I get error messages saying it can't find the aggrs (it goes through each aggr in the resource pool).

Running the "Diagnose Connectivity" test from Ops Mgr shows all ports accessible on the PROD controller except for SNMP.

How is DFM/Provisioning Manager detecting the aggregates? 

Jeff

DFM/Provisioning Manager connectivity problem

Hello Jeff,

 

     As long as you are able to reach the array( storage system) using ping from your DFM server, being in a different subnet may not be of much importance. Are you able to ping you storage systems from your DFM server?

Second thing:

@

I get error messages saying it can't find the aggrs (it goes through each aggr in the resource pool).

-----------------------------------------------------------------------------------------------------------------------------------------------------

Can't find aggrs is actually can't find a "suitable" aggr ( or host ) in the Resource pool and it goes through each aggr showing the details and possible eason why it wasn't selected.  This means aggrs are detected, but prov. mgr failed to select aan aggr which could be dure to one of the possible shown reasons in the error. If you can provide the output of the dry-run result ( conformance) when you are trying to provision, we can point out the possible reason for failure.

@

Basically, when I use provisioning manager on an array in DEV, where DFM is running, it works.

--------------------------------------------------------------------------------------------------------------------------------------------

In this case this particular filer must be meeting all the required condition for provisioning. Being in the same subnet is not the reason that it works for this filer.

Aggrs are detected using SNMP queries and the monitor responsible is fsMon.

Thirdly,

@

Running the "Diagnose Connectivity" test from Ops Mgr shows all ports accessible on the PROD controller except for SNMP.

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Are you using SNMP V1 or V3. By default its always SNMPV1.

SNMP timeout may occure due to DFM server and the arrays being in different subnets and hence diagnose connectivity failed for SNMP. If that is the case, the problem shifts direction, but that needs to be seen once you are through the first 2 parts.

warm regards,

Abhishek

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.