Subscribe
Accepted Solution

DFM not sending email

Hi All,

Have question about DFM not sending email when more than email ID was set in one "administrator names".

Site_Admins  ALL@someting.com,ADMIN_Only@something.com,asia_list@something.com   view     edit

But when only one email specified in one "administrator names". It is working fine.

adminA adminA@something.com     view     edit 

What makes me more confused.The notification that i received clearly showing the other email id that they didn't received.

My question here is, is the configuration correct or there is a know issue about this.

BTW, my DFM version is 3.5.

thanks for the help

Re: DFM not sending email

Hi,

DFM has come a long way from 3.5. Right now the version is 4.0. So my answers might not be accurate. I believe you are trying to set alarms (email based notifications) for DFM events. If that's the case have you tried specifying multiple email id's at the following section (Non-Admins Check screenshot 1).

My guess is that you are trying to specify email recipients in "Admins" section - Here you can specify the email recipients of users who are registered as admins of DFM.

Thanks and regards

Shiva Raja

Re: DFM not sending email

Thanks Shiva for the answer. But, actually i'm not trying to configure it because i don't have permission.

I Just want to confirm is that the cause of the email was not delivered? Or the way the user group was defined was not correct.

Sorry for the confusion.

Thanks

Re: DFM not sending email

Hi,

If possible, ask the client to specify the email ID's in the non-admins section (for test purpose) and try to test the alarm and see if you're able to recieve email notifications.

Thanks and regards

Shiva Raja

Re: DFM not sending email

Check the alert.log and dfmeventd.log under the install directory for any errors.

regards

adai

Re: DFM not sending email

I receive below error on all email that was not delivered.

Sep 18 19:16:06 servername dfmeventd: SMTP server did not like recipient C_ALL@something.com,B@something.com,asia@something.com
and i have check the configuration for the email.
# dfm user list
Id    Administrator          Email                    Pager
----- ---------------------- ------------------------ ------------------------
6936  Sitec_Admins        C_ALL@something.com,B@something.com,asia@something.com
All the email in the "Sitec_Admins" group didn't  receive the email.
Is the syntax of the group correct?
thanks

Re: DFM not sending email

maybe i need to specify detail on what i'm saying. Should the separator between the emails is "blank space" or "comma" or "semicolon".

thanks

Re: DFM not sending email

Comma works.Even semicolon will work, don't think space is valid.

Regards

adai

Re: DFM not sending email

I don't think you can specify multiple email addresses for one admin user (IIRC it is supported for quota users.) You can however give multiple addresses when creating the alarm.

Also, the semi-colon is an aberration used by Outlook. The SMTP RFC specifies only comma, and not all email servers support the semi-colon as separator.

Re: DFM not sending email

Hi Hiyer,

Thanks  for the reply, I think i'm close to the answer, But i still need some documentation or manual saying on this.

Tried to find in the internet but not much help. Did you have any link to DFM manual on how to setup DFM.

That will be a great help. thanks