Subscribe

[DFM ]perfAdvisorTransport set to httpOnly, but host uses https.

Hi, All

I used command : dfm diag host [HOSTNAME] to check performance advisor connection.

I got problem about Advisor Transport.

Performance Advisor Checklist

perfAdvisorEnable  Passed

hostType               Passed

hostRevision          Passed

hostLogin              Passed

perfAdvisorTransport Failed <perfAdvisorTransport set to httpOnly, but host uses https>

Does someone know how to change host uses http?

Thanks for your help.

Re: [DFM ]perfAdvisorTransport set to httpOnly, but host uses https.

valen,

See communities post #14399 for instructions on how to specify HTTP access for your host.  This should answer your question.

http://communities.netapp.com/message/14399

The other option is just to specify HTTPS as the means of communicaiton for Performance Advisor.  You can specify this in Operations Manager or Performance Advisor.

Re: [DFM ]perfAdvisorTransport set to httpOnly, but host uses https.

Dear reide:
Thanks for your response.
If I use following command set Advisor Transport to use https,
"dfm host set msznas01 perfAdvisorTransport=httpsOK"
Managemenet Console can get filer data correctly.
>dfm host diag filer01
Network Connectivity
...
HTTP                   Passed (78 ms)
NDMP (login not set)   Skipped
RSH                    timed out
SSH                    timed out
RLM                    Skipped (hostRLMAddress is empty)
XML (https port 443)   Passed (188 ms)
...
Performance Advisor Checklist
perfAdvisorEnabled     Passed
hostType               Passed
hostRevision           Passed
hostLogin              Passed
perfAdvisorTransport   Passed
But our other filers use httpOnly (Global Default)
>dfm host diag filer02
Network Connectivity
...
HTTP                   Passed (0 ms)
NDMP (login not set)   Skipped
RSH                    Passed (141 ms)
SSH                    Passed (453 ms)
RLM                    Skipped (hostRLMAddress is empty)
XML (http port 80)     Passed (0 ms)
...
Performance Advisor Checklist
perfAdvisorEnabled     Passed
hostType               Passed
hostRevision           Passed
hostLogin              Passed
perfAdvisorTransport   Passed
How do I Change XML of filer01 to use http ?

Re: [DFM ]perfAdvisorTransport set to httpOnly, but host uses https.

Dear All:

I found the command to resolve this problem. Just disable HTTP Admin SLL function

> options httpd.admin.ssl.enable off