Subscribe

DWH annotations publishing issue

Hi experts,

I have added some custom annotations and imported data for some defined annotation (datacenter, country name, customer names etc)  in OCI server which I pushed to DWH and published them.

While creating custom reports in report studio based on new data, I found that imported data is still missing, I found "N/A" value for some servers name. After doing R&D I found that datamart I was refering was maintaining historical data and annotation values were not applied to all data because new values for annotations were not published using "init with current" option.

Now as far as I know there are two ways to fix that:

1. I am assuming that user oadmin must have authority to check that option "init with current" because if with admin user "init with current" option is disabled. But since oadmin credentials are not provided in reference books so I cannot do it.

2. Only option I am see, Since my DWH doesn't have performance data so I can go with this:

a. Take backup of inventory database from DWH backup portal

b. Reset DWH database

c. Restore inventory database taken in setp a.

d. Push force annotation from OCI server

f. Publish all annotations with “init with current” option checked

g. Build Now in schedule.

Let me know if I am going in right direction or not. Are there any other better methods to do?

Also verify if I reset my DWH database, will the user account information persist or lost?

Is the user account info backed up in step a?

I have around 20+ users in DWH server, so worried about it. I have taken backup for custom reports.

Re: DWH annotations publishing issue

Hello,

The first question is, what version of DHW & OCI are you using?  Resetting and restoring the DWH is not necessary. 

Q) Let me know if I am going in right direction or not. Are there any other better methods to do?

A) My recommended method is to open a support case as we can help you gain access with the support account, aka oadmin.  Also, when you added the annotations to the OCI system, did you go to the Web Admin Portal and Force Annotation updates?  If you have not, here are the steps:

1 - Login to the OCI Web Admin Portal using an account with administrator privileges.

2 - Click on Troubleshooting, lower left hand column

3 - Select Force Annotation Updates.

This sets a flag for DWH, so the next build process will collect annotation fields that were previously not used.  Example when to use, you add an annotation to servers for "Favorite Movie", since DWH did not know there was an annotation of that name, it will look for new annotation types and create the information on the DWH system.  This allows you to go and select the annotation "Favorite Movie" to be published and initalized.

Q) Also verify if I reset my DWH database, will the user account information persist or lost?

A) The reset will remove all user information.  When you restore the option to restore user information is enabled (checked) by default.  This will put all user information into the DWH version.


Q) Is the user account info backed up in step a?

A) Yes, it is backed up when you use the Web Admin Portal's backup option.  As stated above, the information is restored to the DB by default.  You have to uncheck the option manually.


I have around 20+ users in DWH server, so worried about it. I have taken backup for custom reports.

There are two distinct backup processes for DWH, the database backup via the Web Admin Portal, and the backup of the IBM Cognos datastores, and this includes the custom reports.  You must backup the customer reports through Cognos, or they will be lost during a restore, an upgrade or a disaster recovery.  There is not a way to retrieve customer reports without a backup.  Please reference the Installation and Administration Guide for the Data Warehouse based upon the version of OCI you are running for instructions.  It is best practice and highly recommended to follow the steps to setup scheduled backups of the Cognos datastores to a location that will then be saved to a remote device, i.e. tape, disk, etc...


-kerick

Re: DWH annotations publishing issue

Hi Kerick,


I am using 6.3.2-141 version of OCI.


Yes, I forced the annotation updates on server portal and then after the build I can see those annotation in DWH portal annotation section. What I am saying here is I forgot to check "init with current" when checking ON "Published" checbox. Because of which new annotation are not binded with old data sets, they are only visible in specific month/year dataset when they are imported. For example, I can see custom annotation values in inventory datamart which doesn't maintain historical information but not in other datamarts.


So I want either to undo the step of checking ON the published checkbox or again force OCI to bind new data with current datasets.


BTW I also tried to delete those custom annotation from server, thinking that those will be deleted from DWH after the build process. I then clicked on "Force Update of Annotations for DWH (include deleted objects)" and then from DWH I started new build but I still see those annotation in DWH.


How can I delete those from DWH tables even when they are deleted from OCI server?


Yes kerick, I have taken backup of DWH database, custom reports as well as full content backup (for safer side).

Re: DWH annotations publishing issue

Hi,

I have not seen this issue previously.  The backup and restore situation you described would work.  If you open a support case and cite this thread, it could be run through a lab test and find out. 

To remove the entries would require modifying the contents of the DWH db, which I do not recommend.

The custom annotations stay in place, just are not seen for reports that deal with time frames before or after the dates the resided on the OCI system.

Glad to know you have the backups done correctly.  An issue seen is people do not backup their custom reports, do an upgrade and lose all that work.  Those are never happy moments when people find out they lost data.

Sorry I don't have a more definite answer for this.

-Jim

Re: DWH annotations publishing issue

Jim, Case was opened with support but it was closed with comment

"This is normal behavior.  The Data Center annotation was not published on the historical records in the DWH.  The most recent records in the Data Warehouse database, i.e., those created after the object was annotated in the OCI Client, should have the Data Center annotation. This case has been closed."

I am getting message that there is nothing that I can do to fetch Datacenter value if I refer datamart other than inventory. I don't think it is impossible to do, there might be some workaround for that.

Re: DWH annotations publishing issue

I have the same experience, wherein the deleted annotations in OCI server is not in sync with OCI DWH., even you when a force update is run.

Version: OCI 6.3.3

Does anyone knows how to fix it?