Subscribe
Accepted Solution

Disable fsrm

Hi,

What is the quickest way to disable fsrm. I am doubting a memory leak in it.

Regards,

Babar

Re: Disable fsrm

There are few things to do.

  • First stop the agent monitoring.
[root@lnx]# dfm options list | grep -i agentMonInterval
agentMonInterval                      2 minutes
[root@lnx]# dfm option set agentMonInterval=off
Changed agent monitoring interval to Off.
[root@lnx]# dfm options list | grep -i agentMonInterval
agentMonInterval                      Off
[root@lnx]#
  • If there is any already in-progress walk stop them.

To find the list of walks that are in progress, use the below command.

dfm srm path list

From this stop the ones that are in progress using the below cli.

[root@lnx]# dfm srm walk stop help

NAME

    stop -- Stop SRM Walk

SYNOPSIS

    dfm srm walk stop { all | <object> ... }

[root@lnx]#

To stop any scheduled kick off of the walk do the following.
unschedule the schedules from the path.
Regards
adai 

Re: Disable fsrm

Appreciate it. Thanx.

Babar