Subscribe

Enable SNMP in WFA v2.2

I'm trying to enable SNMP for WFA and when I test it I get the error "Failed sending test notification". 

 

For Management Host, I entered our Spectrum server as the FQDN and left Management Port to 162.

 

Windows Firewall is not started on the server.

 

When I look at the WFA server.log file I see this.

 

2015-05-19 11:43:31,920 ERROR [org.granite.messaging.service.DefaultServiceExceptionHandler] (http-executor-threads - 85) Could not process remoting message: flex.messaging.messages.RemotingMessage {
  source = null
  operation = sendTestSnmp
  remoteUsername = null
  remotePassword = null
  correlationId = null
  destination = SnmpFacadeImpl
  headers = {DSId=D4790FC9-0CE1-4FE6-8CF4-18823BBF7703, DSEndpoint=graniteamf}
  messageId = 2433EB8A-5198-7A7D-4E0A-6D7CE0460B94
  timestamp = 0
  clientId = 22860225-71E1-41C1-934D-10B764BF7D1C
  timeToLive = 0
  body = [snmp_server_name.corplab.intuit.net, 162]
}: WfaSnmpException{Message: SNMP notification could not be sent, Cause: java.lang.IllegalArgumentException: Argument must be an unsigned 32bit value}

....

 

Any suggestions on resolving this?

 

Thanks,

Roger

 

 

Re: Enable SNMP in WFA v2.2

Roger,

    Not able to reproduce this. Did you try giving the IP address of the SNMP host instead of FQDN?

 

WFA send SNMP v1 traps to community public.  I have posted a WFA command to send SNMP trap from you WFA server. Can you try it out and see if SNMP traps are getting received successfully at the other end. 

 

Here: http://community.netapp.com/t5/OnCommand-Storage-Management-Software-Discussions/How-to-send-snap-trap-from-workflow/m-p/99710#M17578

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.