Subscribe

Error Message: No snap-ins have be registered during test connection to VMware Vcenter

    Hi,

when I try to do a test connection in the Credentials part,

and specify the Vwmare Vcenter I receive the message:

No snap-ins have been registered for Widnwos PowerShell version 2.

Any ideas how to solve thi s?

thanks

Eric

Re: Error Message: No snap-ins have be registered during test connection to VMware Vcenter

Hello Eric,

As per the WFA installation and setup guide, you have to install the PowerCLI package from VMware for working with VMware through WFA.

It is not delivered as part of the installation kit. You can find it online easily here:

http://communities.vmware.com/community/vmtn/server/vsphere/automationtools/powercli?rct=j&q=&esrc=s&source=web&cd=1&ved=0CJYBEBYwAA&url=http://www.vm...

Best,

Yaron Haimsohn

WFA team

Re: Error Message: No snap-ins have be registered during test connection to  VMware Vcenter

Hi,

thanks. I forgot to install the PowerCli package:-)

But now I have the following message:

Regards

Re: Error Message: No snap-ins have be registered during test connection to  VMware Vcenter

Hello Eric,

Could you please perform the following actions in order to verify PowerCLI installation and connectivity.

  1. Open PowerShell shell (run powershell.exe)
  2. Type Add-PSSnapin VMware.VimAutomation.Core and press Enter
  3. Type Get-PowerCLIVersion and press Enter - you should see that the installed version is 5.0.1
  4. Type Connect-VIServer -Server <your_server_address> -Protocol https -User <your_user_name> -Password <your_password> and press Enter
  5. At this point you should be successfully connected

Let me know if you are able to connect and provide me with the output of Connect-VIServer command.

Regards,

Sasha Korman,

WFA team

Error Message: No snap-ins have be registered during test connection to  VMware Vcenter

Hi,

steps done. See result:

Eric

Re: Error Message: No snap-ins have be registered during test connection to  VMware Vcenter

Great, it means that you don't have any problems with installation and you are able to connect manually.

Now, perform the following steps:

  1. Go to credentials screen
  2. Define new credentials (exactly as you in manual mode)
  3. Press "Test" button

What message do you get?

Additionally, what is WFA service log on user?

You can see it at Windows service panel:

  1. Go to services
  2. Right click on "NetApp WFA Server"
  3. Select properties

Regards,

Sasha Korman,

WFA team

Error Message: No snap-ins have be registered during test connection to  VMware Vcenter

Hi,

still the same problem:

User:

Error Message: No snap-ins have be registered during test connection to  VMware Vcenter

2012-05-08 10:43:37,943 CEST INFO  [com.netapp.wfa.ui.LogServiceImpl] (http-0.0.0.0-80-1) [unknown] com.netapp.wfa.ui.app.main.MainView - >>>>> Client Started initMainView setting to state>>>>>>Guest

2012-05-08 10:46:27,862 CEST ERROR [com.netapp.wfa.ui.LogServiceImpl] (http-0.0.0.0-80-2) [unknown] com.netapp.wfa.ui.app.main.ErrorController - Server fault. Please refer to the logs for more info.

Re: Error Message: No snap-ins have be registered during test connection to  VMware Vcenter

Actually you've got two error messages one of them might lead us to the problem.

Please configure ASUP and send it.

Go to:

  1. Tools -> WFA Configuration
  2. Configure it
  3. Press "Send Now" button

Once received, I'll pass over logs and notify you about my findings.

Regards,

Sasha Korman,

WFA team

Error Message: No snap-ins have be registered during test connection to  VMware Vcenter

done

Thanks for your support !