Subscribe
Accepted Solution

Error adding WFA Credential

[ Edited ]

 10-24-2016 3-24-27 PM.png

 

I have tried using the IP, the short host name, and the FQDN for the filer I'm trying to connect to.

 

I opened a telnet session to port 80 on the target filer and the response was HTTP/1.1, so this error sort of makes sense. Can I tell WFA to use HTTP/1.1?

 

Here is the output of the telnet session:

 

HTTP/1.1 302 Found
MIME-Version: 1.1
Server: NetApp//8.2.3P3
Date: Mon, 24 Oct 2016 18:00:04 GMT
Content-Length: 264
Content-Type: text/html
Location: /na_admin/

<HTML>
<HEAD>
<TITLE>Redirection</TITLE>
</HEAD>
<BODY>
<H1>Redirection</H1>
This document can be found
<A HREF="/na_admin/">elsewhere.</A><P>
You see this message because your browser doesn't support automatic
redirection handling.<P>
</BODY>
</HTML>

 

I have a domain account on the filer that I am able to access via SSH, so I know the credentials are valid. From a shell, I have to use the format: ssh domain\\user@filer1  ... How does this translate to a credential username? Do I need to escape the backslash?

 

Here is the log output for the failure:

2016-10-24 14:12:43,304 WARN [com.netapp.wfa.ui.ExecutionFacadeImpl] (default task-28) Method validateCredential("HOSTNAME....","RemoteSystemType{id=...") threw:: javax.ejb.EJBTransactionRolledbackException: Credential validation failed. Connection to HOSTNAME.com failed (13001: Failed to get the hostname corresponding to the server: HOSTNAME.com. Please provide a fully qualified domain name of the server or use HTTP 1.0)

--- SNIP ---

Caused by: CommandExecutionException{Message: Credential validation failed. Connection to HOSTNAME.com failed (13001: Failed to get the hostname corresponding to the server: HOSTNAME.com. Please provide a fully qualified domain name of the server or use HTTP 1.0), Cause: null}

 

Please let me know how I can further troubleshoot this issue. Thanks!

 

EDIT: Using WFA v4.0.0.0.0

 

10-24-2016 5-55-11 PM.png

Re: Error adding WFA Credential

Hi,

You get 'Please provide a fully qualified domain name of the server or use HTTP 1.0' error if the host name not getting properly resolved.

 

To resolve this issue, perform either of the following steps:
 - Configure the DNS server correctly to allow proper DNS resolution.
 - Configure the host file on the OnCommand Workflow Automation Server system to enable the DNS resolution of host names.

Re: Error adding WFA Credential

Hello, thank you for your response. I have opened a command prompt on the WFA server. I did a ping and an nslookup for both the short name and FQDN for the filer host. They were successful in returning the correct IP address. Does this test confirm that DNS is resolving correctly?

 

Is there a way I can specify DNS servers for WFA?

 

10-25-2016 10-11-26 AM.png

Re: Error adding WFA Credential

@ak47

 

I'm trying this on my setup, I'll get back to you very soon on this.

 

On the below point:

 

From a shell, I have to use the format: ssh domain\\user@filer1  ... How does this translate to a credential username? Do I need to escape the backslash?

 

Can you paste the screenshot of how are you currently providing the credentials which is throwing the mentioned error.

 

 

sinhaa

 

 

 

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Error adding WFA Credential

@ak47

 

Can you try providing the credentials like below:

 

Credentials.png

 

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Error adding WFA Credential

[ Edited ]

Hi @sinhaa

 

I tried the credentials as suggested, it did not work.

 

I have taken a packet capture of the connection attempt to the filer. I can conclusively state that DNS is supplying the correct IP.

 

The TCP handshake is completed for both port 80 and port 443, but nothing further happens afterwards. The connection shuts down without ever making a formal HTTP request.

 

The .17.18 machine is the filer, and the .120.125 machine is our WFA virtual machine.

 

10-26-2016 10-50-31 AM.png

Re: Error adding WFA Credential

Can you add the mapping of IP addresses to host name in hosts file located at C:\Windows\System32\drivers\etc ,  and see if it works.

Re: Error adding WFA Credential

[ Edited ]

@ak47

 

I don't have a 7Mode system with me, but now I'm beginning to think it may not be a WFA issue.

 

You said that you can do SSH and connect to the 7Mode controller. WFA credentials for ONTAP uses perl and HTTP protocol to connect to the controller.

 

Now is your 7Mode controller configured for domain login using HTTP?

 

 

Do this below test:

 

1. go to WFA\bin

2. Launch the file ps.cmd

3. Try the below command:

 

Invoke-NaSsh -Name <filer-ip> -Credential DOMAIN\user1 -Command version

 

Provide password when prompted for.

 

 

 

if 3 Passed, and it should since you say SSH works for you.

 

4. Try the below command

 

Connect-NaController -Name <filer-ip> -Credential DOMAIN\user1

 

Provide password when prompted for.

 

provide the results here.

 

 

sinhaa

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Error adding WFA Credential

@sinhaa

 

Here are the results of the testing, everything looks like it is connecting as it should:

 

10-31-2016 10-19-12 AM.png

Re: Error adding WFA Credential

@rkiran

 

Embarassingly, this is what ended up working. It doesn't make any sense to me, given what I've posted previously for my DNS testing, but this was the solution.

 

10-31-2016 10-29-59 AM.png

 

Thank you!!