Subscribe

Error executing "options ndmpd.preferred_interface" on storage system

Dear Community Members,

I have something strange with my DataSet:

Error Message:

MyControler.mydomain.com: Error executing "options ndmpd.preferred_interface" on storage system 'MyControler' (131). Please check the host login protocol setting, the error could be due to an issue with the current setting. If you would like to allow work to be done on a non-preferred interface when there is an issue obtaining the preferred interface, please set the dfm option ndmpDataUseAllInterfaces=1. (null)

I have a Preferred ndmp Interface, I do not have any credential isssue.

 

BTW:

I do not understood what is wrong in my configuration.

Re: Error executing "options ndmpd.preferred_interface" on storage system

I encounter the same.  Ever found the solution ?

Re: Error executing "options ndmpd.preferred_interface" on storage system

Hi Guys,

Yesterday, I had same your problem. After few hours , I found out the root cause that about the user permissions. The user that we used to make connections from DFM to Controllers need more permisions to execute command  "options ndmpd.preferred_interface" on controller to get the name of prefered interface + IP address.

I added more permissions "cli-options,cli-ifconfig" to solve this problem

 

Note: DFM execute commands by SSH Connection. You should make sure your configurations about ssh

Re: Error executing "options ndmpd.preferred_interface" on storage system

I have this problem too but it doesn't seem to be a user rights issue because my NDMP user is in the administrators group with admin role which has cli.*. It's not a problem accessing the filer with SSH because I use PuTTy+SSH from the same Windows box to manage my filers. And it's not an issue with my NDMP user since I just re-set that up in DFM and copy & pasted the NDMP password (plus it works once I enabled the DFM option mentioned in my next paragraph).

 

As suggested by Netapp Management Console (NMC), I set the dfm option to user all interfaces. After doing that, my job in NMC still did an event "retrieving preferred interfaces" and it succeeds and finds my main VIF that I want it to use, along with my e0M management interface. Luckily, it appears to be using the main VIF like I want, because I have NDMPD logging enabled and it makes connections on the VIF and doesn't make any connection on the e0M. The job succeeds, so I guess this works fine for me.

 

Could this be a bug? Anyone out there able to set the preferred NDMP interface and still use NMC for SnapVault backups without setting DFM to user all interfaces for NDMP?

Re: Error executing "options ndmpd.preferred_interface" on storage system

Re: Error executing "options ndmpd.preferred_interface" on storage system

Had the same problem after upgrading from OnCommand Core 5.2.0 to 5.2.1

 

As suggested I set ndmpDataUseAllInterfaces=1 and everything is working as expected again. I am not sure if this is a coincidence, but it seem it really picks the preferred interface.

As also mentioned this is related to BUG 459973 - perhaps this is just a really misleading instruction and could be explained better.

Re: Error executing "options ndmpd.preferred_interface" on storage system

Hi!

 

I also had a customer where after Upgrade from 5.2 to 5.2.1 the Snapvault transfers where suddenly using the "e0M" port.

Now we also changed "ndmpDataUseAllInterfaces" to "1" and the right interface which is specified in "ndmpd.preferred_interface"!

--> thanks Alexander!

All NetApp Documentation tells us to set the "ndmpDataUseAllInterfaces" to "0" in order to use the interface from "ndmpd.preferred_interface"!

- so it seems that with OCUM 5.2.1 it is exactly the other way around - but ist is not documented anywhere ! (?)

 

Can somebody from NetApp Engineering respond and verify what has changed here and in case my assumptions are right just make sure to add this to the Release Notes!

 

regards,

Helmut