Community

Subscribe
Highlighted

Error message while acquiring VC datasource

Greetings,

For the past 5 days, we've been seeing this error logged when WFA tries to acquire the Virtual Center datasource:

Cannot bind argument to parameter 'Disks' because it is null.

Has any one seen this and knows what the problem is?

Phil

Re: Error message while acquiring VC datasource

Here's a screenshot.

Re: Error message while acquiring VC datasource

Hi Phil,

     This is a known issue in VC Data Source acquisition and its planned to be fixed in the future WFA releases. The cause for this failed acquisition is that one or more of your Virtual machines don't have any disks. By default at least 1 disk is always created at the time of creating a VM. However a user can later edit the VM configuration and even delete this disk. But this VM is now of no use.

Till the solution is available in the WFA future builds, I can suggest a workaround. Delete those VMs which don't have any disks or add some disks to those. Then try WFA VC Datasource acquisition, it should work fine.

Let me know it you need any more help.

-Abhishek

Re: Error message while acquiring VC datasource

I've found a similar bug with the vcenter datasource in WFA 2.0.1.  If a Datacenter object has no children, the acquisition errors out with "You cannot call a method on a null-valued expression".  Removing the empty datacenter seems to be one workaround.

Re: Error message while acquiring VC datasource

Phil,

     The fix will be available in the next WFA release which is expected soon.

Re: Error message while acquiring VC datasource

Keemola,

            This is a known issue, but I'm not sure if its in the road-map to fix this issue in the near future. Your workaround is correct.