Subscribe

Error while setting up netapp-harvest

Hi,

thanks for such a wonerful tool.

 

I am triying to setup harvest-graphite but got stuck in setting up harvest.

 

followed all steps as mentioned in the PDF but getting below error.

 

root@osboxes:~# service netapp-harvest status
● netapp-harvest.service - LSB: Start NetApp Harvest collectors at boot time
Loaded: loaded (/etc/init.d/netapp-harvest; bad; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2016-05-27 20:51:52 AEST; 12h ago
Docs: man:systemd-sysv-generator(8)

May 27 20:51:52 osboxes systemd[1]: Starting LSB: Start NetApp Harvest collectors at boot time...
May 27 20:51:52 osboxes systemd[1]: netapp-harvest.service: Control process exited, code=exited status=203
May 27 20:51:52 osboxes systemd[1]: Failed to start LSB: Start NetApp Harvest collectors at boot time.
May 27 20:51:52 osboxes systemd[1]: netapp-harvest.service: Unit entered failed state.
May 27 20:51:52 osboxes systemd[1]: netapp-harvest.service: Failed with result 'exit-code'.

 

 

conf file is attached

 

regards

Kaparwan Manoj 

 

 

 

Re: Error while setting up netapp-harvest

updates....

 

 

root@osboxes:/var/log/graphite# /etc/init.d/netapp-harvest start
STATUS POLLER SITE
############### #################### ##################
[STARTED] fas3270 netapp1
root@osboxes:/var/log/graphite# /etc/init.d/netapp-harvest status
STATUS POLLER SITE
############### #################### ##################
[RUNNING] fas3270 netapp1

 

 

so using /etc/init.d/netapp-harvest it works.. so looks service 'netapp-harvest' is not created/working properly ?

 

Re: Error while setting up netapp-harvest

Hi @Kaparwan

 

 

The startup script provided doesn't set any return codes which some init systems (and config mgt systems) don't like.  This will be be fixed in the forthcoming version of Harvest.  Most likely the service script did actually start it; run "ps -ef | grep harvest" and see if it is running.

 

 

Cheers,
Chris Madden

Storage Architect, NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!

 

 

Re: Error while setting up netapp-harvest

Simillar problem here with Ubuntu 16.04 LTS. inid.d script does not automaticaly start harvest during boot and exits with error.

 

 

netapp@grafana:~$ sudo systemctl status netapp-harvest
● netapp-harvest.service - LSB: Start NetApp Harvest collectors at boot time
   Loaded: loaded (/etc/init.d/netapp-harvest; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2016-06-20 11:41:45 CEST; 1min 0s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 909 ExecStart=/etc/init.d/netapp-harvest start (code=exited, status=203/EXEC)

 

 

Manual start is ok: Even manual run of sudo /etc/init.d/netapp-harvest start is ok.

 

Solution is put this line as first line into /etc/init.d/netapp-harvest

#! /usr/bin/env bash

 

Hope it helps you.

 

@maddenthanks for such great tool!