Subscribe
Accepted Solution

Execution URI input line was not set.

[ Edited ]

When I issue wfa cmdlets from the POWERSHELL cli or ISE I always get the error "Execution URI input line was not set." I know this was covered once but the solution that was given (re-install wfa 3.1) doesn't fix my issue, I tried. I want to be able to issue wfa cmdlets in the ISE or CLI so I can see the values that are being returned as well as do some testing.

 

I am using the latest dataontap powershell tool kit & I upgraded the data ontap modules in WFA using the instructions http://community.netapp.com/t5/OnCommand-Storage-Management-Software-Discussions/How-to-upgrade-or-modify-the-DataONTAP-Powershell-Toolkit-PSTK-in-WFA...

 

My profile looks like this:

 

Import-Module "C:\Program Files (x86)\NetApp\NetApp PowerShell Toolkit\Modules\DataONTAP"

 

Import-Module 'C:\Program Files\NetApp\WFA\PoSH\profile.ps1' <--- I commented out the DataONTAP module

 

if ( !(Get-Module -Name VMware.VimAutomation.Core -ErrorAction SilentlyContinue) ) {
. 'C:\Program Files (x86)\VMware\Infrastructure\vSphere PowerCLI\Scripts\Initialize-PowerCLIEnvironment.ps1'
}

 

Any suggestions other than re-install WFA would be appreciated.

 

Thanks,

Matt

Re: Execution URI input line was not set.

Matt,

 

WFA cmdlets are in 3 different Modules:

 

  1. WFA
  2. WFAWrapper
  3. WFAConfig

 

How to see them: Go to WFA->Help->Support Links -> WFA Powershell cmdlets help.

 

You can see the cmdlets for every WFA Module.

 

1. WFA: NO cmdlets from this module can be called outside of WFA. You'll always get the error as you have been getting. No restarting or reinstalling can fix it. Its not a bug, this is how its sipposed to work.

2. WFAWrapper : Some cmdlets can be called from outside. Others will throw same error.

3. WFAConfig : All cmdlets in this module can be called from Outside. Infact they should always be called from outside.

 

 

sinhaa

 

 

 

 

 

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Execution URI input line was not set.

Thank you for the reply