Subscribe

Export from WFA3.1p2 and Import to WFA-3.1p2 failing, how to resolve?

I'm attempting to provide a set of workflows, commands, filters, finders, etc from one WFA 3.1p2 system to another 3.1p2 system. I create the .dar by doing a 'Category' Export.

 

I get this error no matter what I try. Can anyone provide a clue as to how to research and figure out waht is causing the problem. I've opened the dar (renamed to .zip and examine) but do not see a filter called with this UUID.

 

FAILED-TO-IMPORT.png

Re: Export from WFA3.1p2 and Import to WFA-3.1p2 failing, how to resolve?

[ Edited ]

... and don't see any other function, command, workflow, filter, finder, etc ending in ... 55ff

Re: Export from WFA3.1p2 and Import to WFA-3.1p2 failing, how to resolve?

@dkorns

 

The error means that a 'Filter' whose UUID is as given in the error message is being used in one of your workflows, but exporting it has been prevented by WFA due to it being NetApp/PS certified contents. Your resultant dar doesn't have this filter and hence this dar can't be imported. There might be other such objects in the resultant dar other than thid filter. The error message is thrown for the first such content encountered. 

 

 

How to know which is this filter?

 

On your web browser, execute this api: http://<WFA Server>/rest/filters/87636742-6b94-4ef7-b953-f80d074955ff

 

This will bring out which is this culprit unexportable filter which is not present in the destination WFA server.

 

I tried myself on my WFA and it seems it is: 

 

 
<filter xmlns:atom="http://www.w3.org/2005/Atom" id="87636742-6b94-4ef7-b953-f80d074955ff">
<name>Filter Storage Virtual Machines by cluster</name>
<certification>NETAPP</certification>
<parameters>
<parameter>cluster_name</parameter>
</parameters>
<dictionaryName>cm_storage.Vserver</dictionaryName>
<version>
<major>1</major>
<minor>0</minor>
<revision>0</revision>
</version>
<atom:link rel="self" href="http://localhost:90/rest/filters/87636742-6b94-4ef7-b953-f80d074955ff"/>
<atom:link rel="list" href="http://localhost:90/rest/filters"/>
<atom:link rel="test_no_reservations" href="http://localhost:90/rest/filters/87636742-6b94-4ef7-b953-f80d074955ff/test_no_reservations"/>
<atom:link rel="test" href="http://localhost:90/rest/filters/87636742-6b94-4ef7-b953-f80d074955ff/test"/>
</filter>
 
 
How to fix it?
You can't export this filter. You need to import the NetApp Certified Pack which has filter into the destination WFA before importing the dar. I'm right now not sure this filter was in which pack.
 
sinhaa
If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Export from WFA3.1p2 and Import to WFA-3.1p2 failing, how to resolve?

Thank you Sinhaa, 

 

You saved me hours of process-of-elimination tests to narrow this down. Yes, it turns out the "Filter Storage Virtual Machine by Cluster" is a component of the SLO Pack which is installed on my source WFA system and not the destination WFA system. I noticed that several other filters with the same "last modied dates" referenced SLO concepts which is how I associated it with SLO pack.

 

I happened to use a Filter from SLO in a Finder I created and had NOT realized or noticed it was was from SLO and not a cDOT-builtin filter.

 

BTW, once I knew what the culprit Filter was, the way I determined what (in my code) was USING IT was to attempt to delete the filter. It is a messy way to determine it, but I've found that in WFA, attempting to delete something which you know is in use, but you're NOT sure by what, is to try and delete it. After it asks if you are sure you want to delete it (say yes), it will fail and show you what other component is using it. Wonder if there is a more straight forward way to see those dependencies.

 

This may be my only problem but if not, at least you gave me some tools to interpret and research any other such mishaps. I had not considered the "un-export'able" filters/etc issue.

 

Thanks again.

Re: Export from WFA3.1p2 and Import to WFA-3.1p2 failing, how to resolve?

[ Edited ]

Hum. My next export/import failure is related to a command. After resolving the above, I get a similar import error but related to a command:

 

-----

Failed to import provided data.

Failed to resolve reference - id '4146ee9b-6909-4a56-a2b4-b10965b83557' , target 'CommandDefinition'

-----

 

Any tricks for figuring out the UUID of a command, or commands. Since commands can't be rest invoked I can't use the /rest/command/<uuid> trick.

 

This is probably a similar mistake (unknowling using a NETAPP or PS certified command) but I'm going to have to use a hunt-and-peck method to find this one. 

Re: Export from WFA3.1p2 and Import to WFA-3.1p2 failing, how to resolve?

OKay, that one was easier to resolve based on looking around and thinking about it. I just looked at Certified commands on my source WFA server and saw and remembered that my set of workflows had one that is dependent on the cetified Quota Management Pack. Once I installed that Pack my destination WFA system, my WFA package imported without error.

 

This series of issues makes me wish for two features:

 

  • A column in all designer tab lists that shows the UUID of components, or maybe a "Get Info" function that lets one see the UUID
  • A right-click function choice that shows what other elements are dependent on this element (similar to what delete presents before deleting something)

 

Thanks again

Re: Export from WFA3.1p2 and Import to WFA-3.1p2 failing, how to resolve?

@dkorns

 

Any tricks for figuring out the UUID of a command, or commands. Since commands can't be rest invoked I can't use the /rest/command/<uuid> trick.

----

If you are using WFA4.1 then this can be obtained. WFA4.1 has provided some new APIs which can help you.

 

you need to know 2 things:

 

1. In WFA4.0 and above, all NetApp certified content are a part of some pack. 

2. And WFA4.1 provided REST api rest/packs  and rest/packs/{pack_uuid} to list the pack details. This will show all kinds of contents ( wokflows, commands, functions, templates everything ) in the pack with their UUID

 

 

 

 

This series of issues makes me wish for two features:

-------

 

We can look to solve some of these in future.

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.