Subscribe

Fresh install of OnCommand System Manager 3.1.1 = corrupt database...?

I'm on a Windows 8.1 desktop and attempting to install System Manager. After initial installation, when running I get an error stating the database is corrupt and to consult the heading "Unable To Launch System Manager" in the Release Notes. It states the database is corrupt and to copy the backup database file onto the regular database file, and the path for the files is C:\Users\user_name\NetApp\SystemManager\. This folder does not exist, all the options in System Manager are greyed out, and there were no configuration options during installation. Some cursory searching of the C:\ drive does not yield any NetApp folder other than in Program Files. I've already tried uninstalling and reinstalling, and got the same error.

It should be noted that the software does launch, it just errors out right after the page is loaded.

Any ideas? I haven't ever installed this software before, but the installation was relatively straightforward and am unsure how else to proceed.

Re: Fresh install of OnCommand System Manager 3.1.1 = corrupt database...?

Hi,

I checked on a couple of things.  I installed 3.1.1 on a Windows 8 Enterprise machine (logged in as Administrator) and was able to invoke System Manager after a successful install.  Also, I walked the path you described above in Windows explorer and was able to track all the folders for this product down without any issues.  Not sure if something got botched during the install.  Since yours is a fresh install, would you mind giving it another shot?  If not, I can understand.  Please log a support case so that we can help you get beyond this roadblock.

Thanks!

-Vijay

Re: Fresh install of OnCommand System Manager 3.1.1 = corrupt database...?

Doing a fresh install was actually my first step. After that failed I posted here. Depending on what was discussed here, my next step is to open a ticket and have someone take a look. It's most likely something obvious or simple.

I did try to create the NetApp folder under the user folder I'm logged in as, and was able to create it. I did verify System has full access to the folder as well.

Re: Fresh install of OnCommand System Manager 3.1.1 = corrupt database...?

Thanks for confirming that you already tried a fresh install.  Please go ahead and open a case so that we can collect all the data we need. Thanks!

Re: Fresh install of OnCommand System Manager 3.1.1 = corrupt database...?

I got the same error, to include "systemmanager.ks is corrupted".  Renaming systemmanager.ks fixed the problem.  I my case, there was a c:\users\user_name\netapp\systemmanager\ folder.  My 1st install had been an upgrade, then a repair, and finally, I removed and did a fresh install.  All got me the same error.  I then renamed systemmanager.ks to systemmanager.ks.old, which fixed the problem.  OCSM remembered all the storage systems I had previously entered under the previous OCSM 3.1 I was running, but forgot all of my credentials.

Re: Fresh install of OnCommand System Manager 3.1.1 = corrupt database...?

I ended up speaking with some support techs about issues, and ended up resolving the issue. I'll post here in case anyone runs into it again.

I installed System Manager on a Windows 8.1 VMware Fusion VM on a Mac. The problem was that for whatever reason, when you have Shared Folders turned to ON, specifically sharing the Desktop, it causes System Manager to fail when running. The files within the user profile do not get created, or accessed if previously created, with this option enabled. So the resolution is to simply turn Shared Folders -> Desktop off, and it works fine.

Re: Fresh install of OnCommand System Manager 3.1.1 = corrupt database...?

Agentmith,

http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=752677 may have been shared with you when you spoke to support personnel. Just putting it out there for anyone else who may stumble into the same problem.

Re: Fresh install of OnCommand System Manager 3.1.1 = corrupt database...?

This worked - Thanks