Subscribe

Getting error when defining export rules in a table for WFA workflow

[ Edited ]

Hello all smart people.

I'm trying to create a workflow to create a volume with NFS export.

But I'm stuck on the export rule part, the software isn't accepting my variable for clientmatch, ro, rw and superuser that Iam supposed to get from the export rule table.

 

It feel's like I have looked everywhere and it all looks like the default "create a clustered data ontap nfs volume", but it's not working.

 

Under here is how it's configured and what defenition I have in the workflow command:

 

The user input tab:

User inputs

 

The workflow command defenitions:

Workflow command

 

getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,1)
getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,2)
getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,3)
getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,4)

 

This is how I test it via the preview function:

Workflow_preview.png

 

And the result is this error:

 

Failed to resolve expression 'getValueAt2D($ExportRuleSpecs,ExportRuleLoopIndex,1)'
Location: 'Create export rule' command > 'Export_Rule' tab > 'Create_Export_Rule' variable > 'clientmatch' property

 

I'd be glad for all help to get past this issue!

 

Regards Martin Sandell

Re: Getting error when defining export rules in a table for WFA workflow

Martin,

 

Would you be able to export that workflow and upload it here (or send me a message and we can coordinate offline) ?  I'd be happy to take a look at the workflow and it's a little easier to do in WFA's editor.

 

Joel