Subscribe

Grafana and Harvest with OCUM and OPM

Hello,

 

Currently I am trying to setup Grafan and Harvest, using OCUM and OPM. I have the data being piped all the way to Grafana at this point, however the Graphite structure and Grafana template variables are not matching up (the data makes it to Grafana, but is not added to the templates). I have attached screenshots and my configuration. I had to obfuscate the real hostnames for privacy reasons.

 

Graphite Browser-blur.png

 

(NetAppHarvest template variables)

 

2017-02-21 14_44_56-Grafana - NetApp Detail_ LUN.png

 

 

This is my configuration at the moment.

 

 

##
## Configuration file for NetApp Harvest
##
## This file is organized into multiple sections, each with a [] header
##
## There are two reserved section names:
##  [global]  - Global key/value pairs for installation
##  [default] - Any key/value pairs specified here will be the default
##              value for a poller should it not be listed in a poller section.
##
## Any other section names are for your own pollers:
##  [cluster-name]     - cDOT cluster (match name from cluster CLI prompt)
##  [7-mode-node-name] - 7-mode node name (match name from 7-mode CLI prompt)
##  [OCUM-hostname]    - OCUM server hostname (match hostname set to system)

## Quick Start Instructions:
## 1. Edit the [global] and [default] sections and replace values in all
##    capital letters to match your installation details
## 2. For each system to monitor add a section header and  populate with
##    key/value parameters for it.
## 3. Start all pollers that are not running: /opt/netapp-harvest/netapp-manager start
##
## Note: Full instructions and list of all available key/value pairs is found in the
##       NetApp Harvest Administration Guide

##
#### Global section for installation wide settings
##
[global]
grafana_api_key   = MASKEDKEY
grafana_url       = https://myhostname

##
#### Default section to set defaults for any user created poller section
##
[default]
graphite_enabled  = 1
graphite_server   = 127.0.0.1
graphite_port     = 2003

## polled hosts defaults
username            = MASKEDDUSER
password            = MASKEDPASSWORD
## If using ssl_cert (and not password auth)
## uncomment and populate next three lines
# auth_type         = ssl_cert
# ssl_cert          = netapp-harves.pem
# ssl_key           = netapp-harvest.key

##
#### Poller sections; Add one section for each cDOT cluster, 7-mode node, or OCUM server
#### If any krys are different from those in default duplicate them in the poller section to override.
##

[netappcluster01]
hostname          = 192.168.0.1
group             = netapp_group
# username        = MYUSERNAME
# password        = MYPASSWORD
# host_enabled    = 0

[netappcluster02]
hostname          = 192.168.0.2
group             = netapp_group
# username        = MYUSERNAME
# password        = MYPASSWORD
# host_enabled    = 0

[netappcluster03]
hostname          = 10.10.0.1
group             = netapp_group
# username        = MYUSERNAME
# password        = MYPASSWORD
# host_enabled    = 0

# ocum (defualt for um)
[cd1001-o86]
hostname                   = ocum-hostname
group                      = netapp_group
host_type                  = OCUM
data_update_freq           = 900
normalized_xfer            = gb_per_sec
template                   = ocum-opm-hierarchy.conf
graphite_root              = netapp-capacity.Clusters.{display_name}
graphite_meta_metrics_root = netapp-capacity-poller.{group}

 

I have tried without these lines which gave me the same result, these are the settings suggested for OCUM with OPM in the manual though.

 

template                   = ocum-opm-hierarchy.conf
graphite_root              = netapp-capacity.Clusters.{display_name}
graphite_meta_metrics_root = netapp-capacity-poller.{group}