Subscribe

Graphite/Grafana/NetApp Harvest installation

Hi Chris,

 

I'm trying to install to install Graphite/Grafana & NetApp Harvest on a freshly installed RedHat 7.1 server. Although I find your instructions very clear in the installation document you made, I'm running in some issues. Can you help me with this...as Google is not my friend in this particular case...

I'm stuck at page 12 of your quick install document:

 

[root@xxxxxxxx tmp]# pip install 'django<1.5'
Collecting django<1.5
Downloading Django-1.4.22.tar.gz (7.8MB)
100% |████████████████████████████████| 7.8MB 51kB/s
Building wheels for collected packages: django
Running setup.py bdist_wheel for django
Complete output from command /usr/bin/python -c "import setuptools;__file__='/tmp/pip-build-J_JzqI/django/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" bdist_wheel -d /tmp/tmpG_XWvfpip-wheel-:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/tmp/pip-build-J_JzqI/django/setup.py", line 69, in <module>
raise RuntimeError('Django 1.4 does not support wheel. This error is safe to ignore.')
RuntimeError: Django 1.4 does not support wheel. This error is safe to ignore.

----------------------------------------
Failed building wheel for django
Failed to build django
Installing collected packages: django
Running setup.py install for django
Successfully installed django-1.4.22

 

[root@xxxxxxxx tmp]# git clone https://github.com/graphite-project/graphite-web.git
Cloning into 'graphite-web'...
fatal: unable to access 'https://github.com/graphite-project/graphite-web.git/': Peer's certificate issuer has been marked as not trusted by the user.
[root@xxxxxxxx tmp]# git clone https://github.com/graphite-project/carbon.git
Cloning into 'carbon'...
fatal: unable to access 'https://github.com/graphite-project/carbon.git/': Peer's certificate issuer has been marked as not trusted by the user.
[root@xxxxxxxx tmp]# git clone https://github.com/graphite-project/whisper.git
Cloning into 'whisper'...
fatal: unable to access 'https://github.com/graphite-project/whisper.git/': Peer's certificate issuer has been marked as not trusted by the user.
[root@xxxxxxxx tmp]#

 

 

Can you perhaps point me in the right direction?

 

Thanks,

Rob

Re: Graphite/Grafana/NetApp Harvest installation

[ Edited ]

These errors are probably caused because  your Linux box is not configured to trust the certificate authority that issued the github certificates.    

 

You can either add the certificate authorities on your Linux box, or you can disable git's validating of SSL certificates using one of these commands before you run your git clone commands.

 

git config --global http.sslVerify false    # Persistent
$ env GIT_SSL_NO_VERIFY=true    # For this session only

 

WARNING: Disabling SSL certificate verification has security implications. Without verification of the authenticity of SSL/HTTPS connections, a malicious attacker can impersonate a trusted endpoint (such as GitHub or some other remote Git host), and you'll be vulnerable to a Man-in-the-Middle Attack. Be sure you fully understand the security issues before using this as a solution.

 

Hope that helps.

Colin

 

EDIT: I can't spell.